SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 07/02/2014, 07:49 PM   #1
kurta999
High-roller
 
kurta999's Avatar
 
Join Date: Apr 2009
Location: Slovakia (HU)
Posts: 913
Reputation: 635
Default Vehicle respawn bug after alt tab

IDK that this bug was reported or not, but this really should be fixed.

When I drive with car, I go to afk for 1-2minutes and go back, then my car willl respawn where it spawned. This bug are reported by lot of players on my server and I also saw this in others servers too. This must be fixed, and "very good" for RP...
__________________
I don't play and have ANY interest in SA:MP anymore! Please do not ask for help, because I'm not going to reply.
kurta999 is offline   Reply With Quote
Old 07/02/2014, 08:14 PM   #2
StreetGT
Banned
 
Join Date: Dec 2008
Location: Portugal
Posts: 1,032
Reputation: 108
Default Re: Vehicle respawn bug after alt tab

maybe it's a script problem. Never happended to me.
StreetGT is offline   Reply With Quote
Old 07/02/2014, 08:21 PM   #3
Abagail
High-roller
 
Join Date: Dec 2013
Location: GetPlayerPos(playerid, pos); Scripter/Mapper.
Posts: 3,133
Reputation: 445
Default Re: Vehicle respawn bug after alt tab

Never happened to me... This must be an issue with your script.

Was it spawned in with CreateVehicle?
Take this example... Notice, the "60" at the end. This indicates the vehicles respawn time. Perhaps, the vehicle had a reset time of around 1-2 minutes? Just a theory, though... I may be wrong...
CreateVehicle(520, 2109.1763, 1503.0453, 32.2887, 82.2873, 0, 1, 60);
Abagail is offline   Reply With Quote
Old 07/02/2014, 08:22 PM   #4
ikey07
High-roller
 
ikey07's Avatar
 
Join Date: Jul 2010
Location: Latvia,Riga
Posts: 1,167
Reputation: 180
Default Re: Vehicle respawn bug after alt tab

Which function you use to create cars? AddStaticVehicle or CreateVehicle or AddStaticVehicleEx and do you use -1 as respawn time, and are you sitting in the car when it happens or just next to it?
__________________
ikey07 is offline   Reply With Quote
Old 07/02/2014, 08:57 PM   #5
Beckett
High-roller
 
Beckett's Avatar
 
Join Date: Feb 2012
Location: www.finalnights-rp.com
Posts: 1,794
Reputation: 104
Default Re: Vehicle respawn bug after alt tab

I had the same issue before I thought its somekind of a SA-MP bug then realized.

Quote:
CreateVehicle(520, 2109.1763, 1503.0453, 32.2887, 82.2873, 0, 1, 30);
__________________
Final Nights Roleplay
The first SA-MP server that is not regulated by administrators.
No OOC hierarchy. Strictly directed by players. Utopian vision.

El primer servidor SA-MP que no está regulado por los administradores.
Sin jerarquías OOC. Estrictamente dirigido por jugadores. Visión utópica.

Primul server de SA-MP care nu este regulat de administratori.
Fără ierarhie OOC. Strict dictat de jucători. Visiune utopică.

Yöneticiler tarafından düzenlenmeyen ilk SA-MP sunucusu.
OOC hiyerarşisi yok. Kesinlikle oyuncular tarafından yönetiliyor. Ütopik görme.


Become a Member of our Discord Channel
Beckett is offline   Reply With Quote
Old 07/02/2014, 10:34 PM   #6
kurta999
High-roller
 
kurta999's Avatar
 
Join Date: Apr 2009
Location: Slovakia (HU)
Posts: 913
Reputation: 635
Default Re: Vehicle respawn bug after alt tab

CreateVehicle/AddStaticVehicleEx with -1 and with 99999 seems doesn't work.
__________________
I don't play and have ANY interest in SA:MP anymore! Please do not ask for help, because I'm not going to reply.
kurta999 is offline   Reply With Quote
Old 10/02/2014, 03:16 PM   #7
Calgon
Banned
 
Join Date: Jan 2009
Posts: 6,129
Reputation: 1127
Default Re: Vehicle respawn bug after alt tab

Print after all instances of DestroyVehicle in your script, to help you determine whether it's a script bug and to try refine what line(s) of code are causing the problem.
Calgon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vehicle respawn FalconWingsX Scripting Help 0 10/11/2012 10:55 AM
I want the vehicle to NOT RESPAWN. Dan. Scripting Help 2 19/04/2012 02:02 PM
Vehicle never respawn ?! Dark734 Help Archive 2 04/12/2010 08:17 AM
vehicle respawn Chris_Mcgrifthd Help Archive 2 18/11/2010 10:44 PM
Respawn a vehicle? Torran Help Archive 5 27/01/2010 04:00 PM


All times are GMT. The time now is 06:28 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.