SA-MP Forums

Go Back   SA-MP Forums > SA-MP > Client Support

Reply
 
Thread Tools Display Modes
Old 14/10/2017, 02:18 PM   #1
sidney123
Big Clucker
 
Join Date: Sep 2011
Posts: 103
Reputation: 19
Default Weird SA-MP crash

Hi all,

I have this weird SA-MP crash on the server I develop for but I can not find the source.
This crash occurs a lot, when I log in to the game and attempt to spawn after entering my password, this following crash occurs:

Code:
SA-MP 0.3.7
Exception At Address: 0x0082C682
Base: 0x04D40000

Registers:
EAX: 0x01780070	EBX: 0x483E0005	ECX: 0x11D4D19A	EDX: 0x0007001D
ESI: 0x0570603C	EDI: 0x00000012	EBP: 0x0177F658	ESP: 0x0177F63C
EFLAGS: 0x00210206

Stack:
+0000: 0x00000000   0x1510A0C8   0x05706040   0x017825FC
+0010: 0x11D0D17A   0x00000021   0x00040020   0x0177F690
+0020: 0x0082417C   0x0188000C   0x0574605C   0x1510A0C8
+0030: 0x0F750688   0x00000000   0x0188000C   0x0177F668
+0040: 0x0177EDD4   0x0177F83C   0x00825EA4   0x00888038
+0050: 0x00000000   0x00734B90   0x007CCF21   0x05706040
+0060: 0x00734BC4   0x05706040   0x0F74E864   0x0F74E864
+0070: 0x00749B93   0x1510A0C8   0x00000000   0x0F74E85C
+0080: 0x0E655B60   0x0177F6F4   0x00000001   0x0053408E
+0090: 0x0F74E85C   0x00734B90   0x00000000   0x00000078
+00A0: 0x0E655B60   0x04DDA62D   0x00000078   0x0DA241E0
+00B0: 0x0E655B60   0x0E655B60   0x0177F710   0x04DEA877
+00C0: 0x00000078   0x12611A6E   0x12611960   0x00000000
+00D0: 0x0E655B60   0x0177FA5C   0x04D43BCF   0x00000078
+00E0: 0x12651650   0x0177F978   0x00000001   0x00000000
+00F0: 0x00000000   0x00000000   0x00000000   0x00000000
+0100: 0x00000000   0x083C7000   0x00000000   0x00000000
+0110: 0x00000000   0x00000000   0x00000000   0x0177F7DC
+0120: 0x060D7020   0x57858CD0   0x060D7250   0x0627CBE0
+0130: 0x714B5A40   0x714B5BB0   0x00000000   0x00000000
+0140: 0x0D98A860   0x0177F830   0x00000000   0x0046992B
+0150: 0x00000002   0x00000000   0x04F5EE0E   0x05048C07
+0160: 0x00200202   0x00200202   0x04FD5A7C   0x00200202
+0170: 0x12651B68   0x0177F950   0x0177FA5C   0x0177F7CC
+0180: 0x00000001   0x00000000   0x0177F950   0x12611960
+0190: 0x12611960   0xC3BF9F9A   0x1260BB71   0x0177FA5C
+01A0: 0x0177F700   0x00000001   0x0000002E   0x00000000
+01B0: 0xF9F14845   0x04FB1900   0x0177F950   0x00007800
+01C0: 0x35C3BA00   0x13D744BE   0xA090C4CE   0x00004158
+01D0: 0x00000000   0x00000000   0x00000000   0x00000000
+01E0: 0x00000000   0x00000000   0x01770000   0x00000178
+01F0: 0x12651650   0x0177FA5C   0x00000001   0x0177F978
+0200: 0x0177F964   0x04E0E79B   0xFFFFFFFF   0x04D4D1EC
+0210: 0x0233FF00   0x00000028   0x00000028   0x00000008
+0220: 0x0177F978   0x00000000   0x00000000   0x00000000
+0230: 0x00000000   0x00000000   0x00000000   0x00000000
+0240: 0x00000000   0x00000000   0x00000000   0x00000000
+0250: 0x00000000   0x00000000   0x00000000   0x00000000
+0260: 0x00000000   0x00000000   0x00000000   0x00000000
+0270: 0x00000000   0x00000000   0x00000000   0x00000000

SCM Op: 0x248, lDbg: 0 LastRendObj: 1232

Game Version: US 1.0

State Information: Ped Context: 0
P0 (0,0) P1 (0,0) P2 (0,0) P3 (0,0) 
P4 (0,0) P5 (0,0) P6 (0,0)
This happens the second time I try to enter, and the third time the system teleports me to the blueberry coords (0.0, 0.0, 0.0) and it marks me as dead. Then I can play fine without any crashes or whatsoever.

Sometimes the log in dialog freezes, I can see trees moving but I can not select any buttons or enter my password. The only way to get out of the game is by signing out and sign back in to the computer user account.

Does anyone have more information about the 0x248 crash OR the dialog freezing?

I have a few mods installed, CLEO only for ELM and I have a sound mod, all work perfectly fine on other servers except the server I script for. It's getting really annoying.

Thanks in advance!
Sidney.
sidney123 is offline   Reply With Quote
Old 14/10/2017, 03:00 PM   #2
Zeth
Huge Clucker
 
Zeth's Avatar
 
Join Date: Feb 2017
Location: Titan
Posts: 428
Reputation: 114
Default Re: Weird SA-MP crash

Use Crashdetect and see the logs and fix them.here
Zeth is offline   Reply With Quote
Old 14/10/2017, 03:11 PM   #3
sidney123
Big Clucker
 
Join Date: Sep 2011
Posts: 103
Reputation: 19
Default Re: Weird SA-MP crash

I already use crashdetect and compile the script in -d3 flags. No errors in server_log
sidney123 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird SA-MP Crash Lorenc_ Client Support 4 10/05/2013 02:55 AM
Weird SA:MP Crash [BB]ExpL0sIv3 Client Support 3 14/12/2012 08:19 AM
weird crash lately.. Donya Bug Reports 1 24/03/2011 10:47 AM
Weird crash, if I add something Memoryz Help Archive 7 01/10/2010 12:47 AM


All times are GMT. The time now is 09:22 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.