SA-MP Forums

Go Back   SA-MP Forums > SA-MP Server > Server Support

Reply
 
Thread Tools Display Modes
Old 23/05/2020, 05:40 PM   #1
Marcop
Little Clucker
 
Join Date: Nov 2016
Posts: 11
Reputation: 0
Default Problem connecting to host

Hi, today I have uploaded the gamemode/server to the host and at the time of putting the server on, I cannot because it gives me the following error:

HTML Code:
----------
Loaded log file: "server_log.txt".
----------
 
SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team
 
[13:21:14] filterscripts = ""  (string)
[13:21:14] 
[13:21:14] Server Plugins
[13:21:14] --------------
[13:21:14]  Loading plugin: crashdetect.so
[13:21:14]   CrashDetect v4.17 is OK.
[13:21:14]   Loaded.
[13:21:14]  Loading plugin: streamer.so
[13:21:14] 
 
*** Streamer Plugin v2.9.4 by Incognito loaded ***
 
[13:21:14]   Loaded.
[13:21:14]  Loading plugin: sscanf.so
[13:21:14] 
 
[13:21:14]  ===============================
 
[13:21:14]       sscanf plugin loaded.     
 
[13:21:14]          Version:  2.8.1        
 
[13:21:14]    (c) 2012 Alex "******" Cole  
 
[13:21:14]  ===============================
 
[13:21:14]   Loaded.
[13:21:14]  Loading plugin: mysql.so
[13:21:14]  >> plugin.mysql: R39-5 successfully loaded.
[13:21:14]   Loaded.
[13:21:14]  Loading plugin: discord-connector.so
[13:21:14]   Failed (libssl.so.1.0.0: wrong ELF class: ELFCLASS64)
[13:21:14]  Loaded 4 plugins.
 
[13:21:14] 
[13:21:14] Filterscripts
[13:21:14] ---------------
[13:21:14]   Loaded 0 filterscripts.
 
[13:21:14] [debug] Run time error 19: "File or function is not found"
[13:21:14] [debug]  DCC_FindChannelById
[13:21:14] [debug]  DCC_SendChannelMessage
[13:21:14] [debug]  DCC_GetChannelName
[13:21:14] [debug]  DCC_GetUserName
[13:21:14] [debug]  DCC_IsUserBot
[13:21:14] [debug]  DCC_GetChannelId
[13:21:14] [debug] Run time error 19: "File or function is not found"
[13:21:14] [debug]  DCC_FindChannelById
[13:21:14] [debug]  DCC_SendChannelMessage
[13:21:14] [debug]  DCC_GetChannelName
[13:21:14] [debug]  DCC_GetUserName
[13:21:14] [debug]  DCC_IsUserBot
[13:21:14] [debug]  DCC_GetChannelId
[13:21:14] Script[gamemodes/gb.amx]: Run time error 19: "File or function is not found"
[13:21:14] Number of vehicle models: 0
I think the problem comes from: "[13:21:14] Loading plugin: discord-connector.so
[13:21:14] Failed (libssl.so.1.0.0: wrong ELF class: ELFCLASS64)". This does not happen when I start it on the localhost...
Marcop is offline   Reply With Quote
Old 24/05/2020, 05:26 PM   #2
God'Z War
Gangsta
 
Join Date: Apr 2012
Posts: 763
Reputation: 102
Default Re: Problem connecting to host

Please check which plugin you installed. If your system is 64bit, Install 64 bit files in your server. Hope this will fix your issue.
__________________

Free SAMP Server Available, Visit us www.knothost.com

!! For paid clients we provide free User Control Panel Website & Player signature for Mysql Based Servers.
!! Provide Free Server Signature
God'Z War is offline   Reply With Quote
Old 02/06/2020, 01:20 AM   #3
KevTheJoker
Big Clucker
 
KevTheJoker's Avatar
 
Join Date: Dec 2018
Location: South America
Posts: 80
Reputation: 7
Default Re: Problem connecting to host

This simply tells you that you're using the 64bit libssl.so.1.0.0 instead of 32bit.

To fix this, use sudo apt-get install libssl1.0.0:i386 and sudo apt-get update for the installations to make changes.
KevTheJoker is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with connecting CoreyDaniels Client Support 2 24/03/2014 08:59 PM
SA-MP Connecting problem TwiZt Client Support 1 13/02/2014 12:43 PM
Server Console Open but no response local host or bots connecting Kyle Server Support 5 28/10/2011 01:46 PM
Connecting to local host... chriswilson Server Support 0 14/03/2010 05:14 PM
connecting problem heneririi Server Support 2 05/12/2008 11:36 AM


All times are GMT. The time now is 08:06 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.