SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 29/03/2020, 05:29 AM   #1
MrCesar
Huge Clucker
 
MrCesar's Avatar
 
Join Date: Sep 2016
Location: Russia
Posts: 290
Reputation: 1
Default SAMP_INCLUDES_VERSION warning

Hello guys, a weird warning I am getting, I am updating to mysql r41-4 plugin, and once I installed the new plugin, and copy pasted the script from here

Now, the script works fine and everything works fine, but after 1 time I launch the server I suddenly start getting these error:

pawn Code:
(381) : warning 203: symbol is never used: "SAMP_INCLUDES_VERSION"

line 381 is the end of the script, it's actual copy paste from the link, nothing was defined by me..

Anyone knows what may cause this error? Thanks!
MrCesar is offline   Reply With Quote
Old 29/03/2020, 05:43 AM   #2
SiaReyes
Gangsta
 
SiaReyes's Avatar
 
Join Date: Mar 2019
Location: Coordinates X,Y,Z
Posts: 622
Reputation: 57
Default Re: SAMP_INCLUDES_VERSION warning

You can find that in a_samp.inc. I don't know for what it is used for. You can comment it!
Code:
public const SAMP_INCLUDES_VERSION = 0x037030;
SiaReyes is offline   Reply With Quote
Old 29/03/2020, 05:47 AM   #3
MrCesar
Huge Clucker
 
MrCesar's Avatar
 
Join Date: Sep 2016
Location: Russia
Posts: 290
Reputation: 1
Default Re: SAMP_INCLUDES_VERSION warning

Quote:
Originally Posted by SiaReyes View Post
You can find that in a_samp.inc. I don't know for what it is used for. You can comment it!
Code:
public const SAMP_INCLUDES_VERSION = 0x037030;
Weird, downloaded a new server and my a_samp.inc doesn't have this line
MrCesar is offline   Reply With Quote
Old 29/03/2020, 05:49 AM   #4
SiaReyes
Gangsta
 
SiaReyes's Avatar
 
Join Date: Mar 2019
Location: Coordinates X,Y,Z
Posts: 622
Reputation: 57
Default Re: SAMP_INCLUDES_VERSION warning

Quote:
Originally Posted by MrCesar View Post
Weird, downloaded a new server and my a_samp.inc doesn't have this line
oh, can you show the full warning?
SiaReyes is offline   Reply With Quote
Old 29/03/2020, 06:00 AM   #5
MrCesar
Huge Clucker
 
MrCesar's Avatar
 
Join Date: Sep 2016
Location: Russia
Posts: 290
Reputation: 1
Default Re: SAMP_INCLUDES_VERSION warning

Quote:
Originally Posted by SiaReyes View Post
oh, can you show the full warning?
Well, now I am getting confused..I've tried compiling it with pawno and it gave no errors, now when I go back to my sublime text is says can't read from file a_samp?


EDIT: found out what was bugging it, the text editor - subslime had it build path set to pawncc.exe from the previous folder version and not the new one..

Last edited by MrCesar; 29/03/2020 at 06:43 AM.
MrCesar is offline   Reply With Quote
Old 29/03/2020, 06:40 AM   #6
MrCesar
Huge Clucker
 
MrCesar's Avatar
 
Join Date: Sep 2016
Location: Russia
Posts: 290
Reputation: 1
Default Re: SAMP_INCLUDES_VERSION warning

EDIT: Please delete, didn't notice the double post..
MrCesar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Warning 213: Tag mismatch and warning 202: number of arguments does not match definition ConnorG Scripting Help 5 12/01/2018 02:32 AM
[Ajuda] warning 217: loose indentation, warning 202: number of arguments does not match definition NATANGameron Português/Portuguese 7 05/04/2017 12:36 AM
warning (7784) : warning 202: number of arguments does not match definition b0b Scripting Help 3 08/06/2014 05:26 PM
warning 215: expression has no effect & warning 235: public function lacks forward declaration botak Scripting Help 4 27/12/2013 12:38 PM


All times are GMT. The time now is 05:33 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.