SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 25/03/2019, 07:09 PM   #1
pwskyline34
Banned
 
Join Date: Sep 2017
Posts: 33
Reputation: 0
Default No command works

I have a Windows server but when I run it on Linux it does not work. Only the login works. HELP!!

Code:
SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[21:25:47] 
[21:25:47] Server Plugins
[21:25:47] --------------
[21:25:47]  Loading plugin: crashdetect.so
[21:25:47]   CrashDetect v4.15.1 is OK.
[21:25:47]   Loaded.
[21:25:47]  Loading plugin: sscanf.so
[21:25:47] 

[21:25:47]  ===============================

[21:25:47]       sscanf plugin loaded.     

[21:25:47]          Version:  2.8.1        

[21:25:47]    (c) 2012 Alex "******" Cole  

[21:25:47]  ===============================

[21:25:47]   Loaded.
[21:25:47]  Loading plugin: streamer.so
[21:25:47] 

*** Streamer Plugin v2.9.2 by Incognito loaded ***

[21:25:47]   Loaded.
[21:25:47]  Loaded 3 plugins.

[21:25:47] 
[21:25:47] Filterscripts
[21:25:47] ---------------
[21:25:47]   Loading filterscript 'Botones.amx'...
[21:25:47]   Loading filterscript 'beachside.amx'...
[21:25:48] 

[21:25:48]   |---------------------------------------------------
[21:25:48]   |--- LS BeachSide Filterscript
[21:25:48]   |--  Script v1.03
[21:25:48]   |--  19th April 2015
[21:25:48]   |---------------------------------------------------
[21:25:48]   |--  LS BeachSide Building Elevator created
[21:25:48]   |---------------------------------------------------
[21:25:48]   Loading filterscript 'LACFDPalomino.amx'...
[21:25:48]   Loading filterscript 'Ayuntamiento.amx'...
[21:25:48]   Loaded 4 filterscripts.

[21:25:48]  
[21:25:48]  
[21:25:48]  
[21:25:48]  ======================================= 
[21:25:48]  |                                     | 
[21:25:48]  |        YSI version 3.09.0684        | 
[21:25:48]  |        By Alex "******" Cole        | 
[21:25:48]  |                                     | 
[21:25:48]  ======================================= 
[21:25:48]  
[21:25:48]  
[21:25:48]  
[21:25:48] » Sistema de graffitis cargado (0).
[21:25:48] » Sistema de objetos dinámicos cargado (163).
[21:25:48] » Sistema de puertas dinamicas cargado (0).
[21:25:48] » Sistema de status del servidor cargado.
[21:25:48] » Sistema de casas cargado (7).
[21:25:48] » Sistema de garajes cargado (0).
[21:25:48] » Sistema de negocios cargado (20).
[21:25:48] » Sistema de gasolineras cargado (4).
[21:25:48] » Incendios cargados.
[21:25:48] » Sistema de teléfonos públicos cargado (0).
[21:25:48] » Sistema de ATMs cargado (0).
[21:25:48] » Sistema de semillas cargado (0).
[21:25:48] » Sistema de micrófonos cargado (0).
[21:25:48] » Sistema de basureros cargado (8).
[21:25:48] |- Cajas dinámicas (0)
[21:25:48] » Sistema de talleres cargado (0).
[21:25:48] # Actores cargados correctamente.
[21:25:48] » Sistema de concesionarias cargado (87).
[21:25:48] » Sistema de vehículos usados cargados (0).
[21:25:48] » Sistema de empresas cargado (3).
[21:25:48] » Sistema de vehículos cargado (3).
[21:25:48] » Sistema de grupos cargado.
[21:25:48] » Sistema de parqueos/peajes cargado (9).
[21:25:48] » Objetos unicos cargado (0).
[21:25:48]  
[21:25:48] SERVIDOR INICIADO CON ÉXITO.
[21:25:48]  
[21:25:48] ===================================================================
[21:25:48] 
[21:25:48] 	
[21:25:48] ===================================================================
[21:25:48]  
[21:25:48] Number of vehicle models: 1


Active nativechecker and this comes out

Code:
[00:51:15]    Error: Function not registered: 'SSCANF_Init'
[00:51:15]    Error: Function not registered: 'SSCANF_IsConnected'
[00:51:15]    Error: Function not registered: 'SSCANF_Join'
[00:51:15]    Error: Function not registered: 'SSCANF_Leave'
[00:51:15]    Error: Function not registered: 'CreateDynamic3DTextLabel'
[00:51:15]    Error: Function not registered: 'CreateDynamicObject'
[00:51:15]    Error: Function not registered: 'CreateDynamicCP'
[00:51:15]    Error: Function not registered: 'DestroyDynamicPickup'
[00:51:15]    Error: Function not registered: 'CreateDynamicPickup'
[00:51:15]    Error: Function not registered: 'DestroyDynamicMapIcon'
[00:51:15]    Error: Function not registered: 'sscanf'
[00:51:15]    Error: Function not registered: 'DestroyDynamicObject'
[00:51:15]    Error: Function not registered: 'Streamer_Update'
[00:51:15]    Error: Function not registered: 'IsPlayerInDynamicArea'
[00:51:15]    Error: Function not registered: 'DestroyDynamic3DTextLabel'
[00:51:15]    Error: Function not registered: 'TogglePlayerAllDynamicCPs'
[00:51:15]    Error: Function not registered: 'SetDynamicObjectMaterialText'
[00:51:15]    Error: Function not registered: 'EditDynamicObject'
[00:51:15]    Error: Function not registered: 'SetDynamicObjectMaterial'
[00:51:15]    Error: Function not registered: 'Streamer_UpdateEx'
[00:51:15]    Error: Function not registered: 'MoveDynamicObject'
[00:51:15]    Error: Function not registered: 'IsValidDynamicObject'
[00:51:15]    Error: Function not registered: 'GetDynamicObjectPos'
pwskyline34 is offline   Reply With Quote
Old 25/03/2019, 07:10 PM   #2
Heress
Huge Clucker
 
Heress's Avatar
 
Join Date: Mar 2018
Location: Lithuania
Posts: 262
Reputation: 7
Default Re: No command works

Update streamer,sscanf include and plugin
__________________
==============
Sorry for my bad English









Respect: Kalcor, ******. Thank you for this great game!
Heress is offline   Reply With Quote
Old 25/03/2019, 07:14 PM   #3
pwskyline34
Banned
 
Join Date: Sep 2017
Posts: 33
Reputation: 0
Default Re: No command works

Quote:
Originally Posted by Heress View Post
Update streamer,sscanf include and plugin
If I update it, it will make mistakes, right?
pwskyline34 is offline   Reply With Quote
Old 25/03/2019, 07:17 PM   #4
Heress
Huge Clucker
 
Heress's Avatar
 
Join Date: Mar 2018
Location: Lithuania
Posts: 262
Reputation: 7
Default Re: No command works

Quote:
Originally Posted by pwskyline34 View Post
If I update it, it will make mistakes, right?
Functions are in newer version. Your version is old, so functions are not registered.
NOTE: don't forget update and linux plugins.
__________________
==============
Sorry for my bad English









Respect: Kalcor, ******. Thank you for this great game!
Heress is offline   Reply With Quote
Old 25/03/2019, 07:24 PM   #5
pwskyline34
Banned
 
Join Date: Sep 2017
Posts: 33
Reputation: 0
Default Re: No command works

Quote:
Originally Posted by Heress View Post
Functions are in newer version. Your version is old, so functions are not registered.
NOTE: don't forget update and linux plugins.
I just updated and remains the same. I can not go to any coordinate, no command works. I fall to the void.
pwskyline34 is offline   Reply With Quote
Old 25/03/2019, 07:27 PM   #6
Heress
Huge Clucker
 
Heress's Avatar
 
Join Date: Mar 2018
Location: Lithuania
Posts: 262
Reputation: 7
Default Re: No command works

Quote:
Originally Posted by pwskyline34 View Post
I just updated and remains the same. I can not go to any coordinate, no command works. I fall to the void.
show your cfg and gamemode lines where you include files.
__________________
==============
Sorry for my bad English









Respect: Kalcor, ******. Thank you for this great game!
Heress is offline   Reply With Quote
Old 25/03/2019, 07:29 PM   #7
pwskyline34
Banned
 
Join Date: Sep 2017
Posts: 33
Reputation: 0
Default Re: No command works

Quote:
Originally Posted by Heress View Post
show your cfg and gamemode lines where you include files.
Code:
echo Executing Server Config...
lanmode 0
rcon_password test
maxplayers 100
port 7802
hostname roleplay
gamemode0 clarp
filterscripts Botones beachside LACFDPalomino Ayuntamiento
language Spanish
plugins crashdetect.so sscanf.so streamer.so
announce 1
query 1
chatlogging 0
weburl test.com
onfoot_rate 40
incar_rate 40
weapon_rate 40
stream_distance 500.0
stream_rate 1000
maxnpc 0
asckslimit 5000
messageslimit 1000
messageholelimit 5000
logtimeformat [%H:%M:%S]
Code:
#include <a_samp>
#include <YSI\y_ini>
#include <YSI\y_timers>
#undef MAX_PLAYERS
#define MAX_PLAYERS			(100)
#include <a_actor>
#include <streamer>
#include <cmd>
#include <sscanf2>
#include <djson>
#include <foreach>
#include <selec2>
#include <mSelection>
#include <yom_buttons>
#include <JunkBuster>
#include <mxINI>
#include <mapeos.inc>
#include <centro.inc>
#include <sintaxis.inc>
#include <a_shop.inc>
pwskyline34 is offline   Reply With Quote
Old 25/03/2019, 07:30 PM   #8
Heress
Huge Clucker
 
Heress's Avatar
 
Join Date: Mar 2018
Location: Lithuania
Posts: 262
Reputation: 7
Default Re: No command works

Then, you updated it wrong.
__________________
==============
Sorry for my bad English









Respect: Kalcor, ******. Thank you for this great game!
Heress is offline   Reply With Quote
Old 25/03/2019, 07:32 PM   #9
pwskyline34
Banned
 
Join Date: Sep 2017
Posts: 33
Reputation: 0
Default Re: No command works

Quote:
Originally Posted by Heress View Post
Then, you updated it wrong.
Introduce both files to plugins and pawno / include, right?
pwskyline34 is offline   Reply With Quote
Old 25/03/2019, 07:36 PM   #10
Heress
Huge Clucker
 
Heress's Avatar
 
Join Date: Mar 2018
Location: Lithuania
Posts: 262
Reputation: 7
Default Re: No command works

Quote:
Originally Posted by pwskyline34 View Post
Introduce both files to plugins and pawno / include, right?
https://github.com/samp-incognito/sa...ses/tag/v2.9.4
download zip. Paste .inc files to pawno >> includes. Plugins files (.dll and .so) paste to folder "plugins".

same with sscanf https://forum.sa-mp.com/showthread.php?t=570927
__________________
==============
Sorry for my bad English









Respect: Kalcor, ******. Thank you for this great game!
Heress is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SERVER UNKNOWN COMMAND, but command works majmunko Scripting Help 7 19/09/2018 09:02 AM
SERVER:Unknown command. error even the command works well GameOvr Scripting Help 20 07/09/2018 02:05 PM
command works but still unknown command?! NicholasA Scripting Help 3 23/05/2013 02:15 PM
Command works, but just return Unknown Command Riddy Scripting Help 9 08/08/2012 03:44 PM
SERVER: Unknown Command but the Command works anantanni Help Archive 13 19/03/2011 05:00 AM


All times are GMT. The time now is 07:16 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.