SA-MP Forums

Go Back   SA-MP Forums > Non-English > Languages > Português/Portuguese

Reply
 
Thread Tools Display Modes
Old 09/11/2016, 02:40 PM   #1
SukMathcuck
Gangsta
 
SukMathcuck's Avatar
 
Join Date: Jun 2014
Posts: 646
Reputation: 2
Wink Colocando o gamemode para funcionar?

E aí, então, hoje quero resolver esse problema, estou com a gamemode aqui e a mesma está parecendo muito complexa, pois só baixei o pwn e não tenho tudo que ela precisa, então pensei em ajuda, comecei do zero, e como por conhecidencia, os erros começou pelas primeiras linhas, inlude, eu não estou em contrando a include?

Code:
#include <filesystem>
Quote:
C:\Users\User\Desktop\gamemode\gamemodes\gamemode. pwn(13) : fatal error 100: cannot read from file: "filesystem"

Compilation aborted.Pawn compiler 3.2.3664 Copyright (c) 1997-2006, ITB CompuPhase


1 Error.
SukMathcuck is offline   Reply With Quote
Old 09/11/2016, 02:45 PM   #2
Eddye
Huge Clucker
 
Eddye's Avatar
 
Join Date: May 2014
Location: Rio de Janeiro
Posts: 365
Reputation: 42
Default Re: Colocando o gamemode para funcionar?

A include não ta na pasta pawno\include

verifique e veja se está lá que o erro some.
__________________
Setup:
Core i5™ 2310 2.9GHz @ 3.4GHz
16GB HyperX Fury 1866Mhz (1X16)
GTX 960 GALAX Exoc Black Edition (Adeus R9 280X)
2 HD's 500GB Seagate
Fonte Corsair CX500
Gabinete Aerocool 800 (2 Fans RED)
Eddye is offline   Reply With Quote
Old 09/11/2016, 02:54 PM   #3
SukMathcuck
Gangsta
 
SukMathcuck's Avatar
 
Join Date: Jun 2014
Posts: 646
Reputation: 2
Default Re: Colocando o gamemode para funcionar?

Quote:
Originally Posted by Eddye View Post
A include não ta na pasta pawno\include

verifique e veja se está lá que o erro some.
Certo, estava, abri o pawn aplicativo errado. +Rep

Acabei de resolver um problema e apareceu isso, tem problema demais, se é loco, mais esse ae pode ser o que? DOF2 desatualizada? Obs: Pode perceber que as gamemodes, calbacks estão separadas da gamemode raiz.

Code:
../gamemodes/OnConnect.pwn(342) : error 017: undefined symbol "DOF2_FileExists"
../gamemodes/OnConnect.pwn(347) : error 017: undefined symbol "DOF2_FileExists"
../gamemodes/OnConnect.pwn(349) : error 017: undefined symbol "DOF2_GetInt"
../gamemodes/OnConnect.pwn(352) : error 017: undefined symbol "DOF2_GetInt"
../gamemodes/OnConnect.pwn(354) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(355) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(356) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(357) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(358) : error 017: undefined symbol "DOF2_WriteFile"
../gamemodes/OnConnect.pwn(359) : error 017: undefined symbol "DOF2_GetString"
../gamemodes/OnConnect.pwn(366) : error 017: undefined symbol "DOF2_GetInt"
../gamemodes/OnConnect.pwn(368) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(369) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(370) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(371) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(372) : error 017: undefined symbol "DOF2_WriteFile"
../gamemodes/OnConnect.pwn(373) : error 017: undefined symbol "DOF2_GetString"
../gamemodes/OnConnect.pwn(380) : error 017: undefined symbol "DOF2_GetInt"
../gamemodes/OnConnect.pwn(382) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(383) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(384) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(385) : error 017: undefined symbol "DOF2_SetInt"
../gamemodes/OnConnect.pwn(386) : error 017: undefined symbol "DOF2_WriteFile"
../gamemodes/OnConnect.pwn(387) : error 017: undefined symbol "DOF2_GetString"
../gamemodes/OnConnect.pwn(398) : error 017: undefined symbol "DOF2_GetInt"
../gamemodes/OnConnect.pwn(413) : error 017: undefined symbol "DOF2_GetInt"

Compilation aborted.Pawn compiler 3.2.3664	 	 	Copyright (c) 1997-2006, ITB CompuPhase


26 Errors.
SukMathcuck is offline   Reply With Quote
Old 09/11/2016, 02:59 PM   #4
SammyJ
Gangsta
 
SammyJ's Avatar
 
Join Date: May 2015
Location: Rio de Janeiro
Posts: 811
Reputation: 71
Default Respuesta: Colocando o gamemode para funcionar?

No topo do gamemode, abaixo de #include <a_samp>
PHP Code:
#include <DOF2> 
__________________
SammyJ is offline   Reply With Quote
Old 09/11/2016, 03:07 PM   #5
Eddye
Huge Clucker
 
Eddye's Avatar
 
Join Date: May 2014
Location: Rio de Janeiro
Posts: 365
Reputation: 42
Default Re: Colocando o gamemode para funcionar?

Conforme você for adicionando as includes no pawno, você tem que defini-las no topo do GM como o amigo Glederson_dom citou em cima ^^

feito isso você resolverá grande parte de seus problemas.
__________________
Setup:
Core i5™ 2310 2.9GHz @ 3.4GHz
16GB HyperX Fury 1866Mhz (1X16)
GTX 960 GALAX Exoc Black Edition (Adeus R9 280X)
2 HD's 500GB Seagate
Fonte Corsair CX500
Gabinete Aerocool 800 (2 Fans RED)
Eddye is offline   Reply With Quote
Old 09/11/2016, 03:28 PM   #6
SukMathcuck
Gangsta
 
SukMathcuck's Avatar
 
Join Date: Jun 2014
Posts: 646
Reputation: 2
Default Re: Respuesta: Colocando o gamemode para funcionar?

PHP Code:
[QUOTE]<div style="margin:20px; margin-top:5px; ">
    <
div class="smallfont" style="margin-bottom:2px">Quote:</div>
    <
table cellpadding="6" cellspacing="0" border="0" width="100%">
    <
tr>
        <
td class="alt2" style="border: 1px solid #C2C2C2; font-size: 8pt;">
            
                <
div>
                    
Originally Posted by <strong>Glederson_dom</strong>
                    <
a href="showthread.php?s=bcac0876a6f9aeee4cb0cf6cbd289b8e&p=3796286#post3796286" rel="nofollow"><img class="inlineimg" src="images/buttons/viewpost.gif" border="0" alt="View Post" /></a>
                </
div>
                <
div style="font-style:italic">No topo do gamemodeabaixo de #include <a_samp></div>
            
        
</td>
    </
tr>
    </
table>
</
div>#include <DOF2> 
[/QUOTE]

Certo, era isso. +rep


Quote:
Originally Posted by Eddye View Post
Conforme você for adicionando as includes no pawno, você tem que defini-las no topo do GM como o amigo Glederson_dom citou em cima ^^

feito isso você resolverá grande parte de seus problemas.
Verdade, acredito que seja isso, mais então, agora apareceu esse erro, provavelmente preciso de qual include, agora sei que precisa da include.

Includes:
Code:
#include <a_samp>
#include <DOF2>
#include <dns>
#include <filesystem>
#include <Foreach>
#include <sscanf2>
#include <streamer>
#include <zcmd>
Quote:
AttachDynamicObjectToVehicle
EditDynamicObject
OnPlayerEditDynamicObject
Code:
../gamemodes/OnCommand.pwn(2611) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(2663) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(2730) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(2834) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(3134) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(8385) : error 017: undefined symbol "AttachDynamicObjectToVehicle"
../gamemodes/OnCommand.pwn(8390) : error 017: undefined symbol "AttachDynamicObjectToVehicle"
../gamemodes/OnCommand.pwn(8395) : error 017: undefined symbol "AttachDynamicObjectToVehicle"
../gamemodes/OnCommand.pwn(8400) : error 017: undefined symbol "AttachDynamicObjectToVehicle"
../gamemodes/OnCommand.pwn(8405) : error 017: undefined symbol "AttachDynamicObjectToVehicle"
../gamemodes/OnCommand.pwn(8410) : error 017: undefined symbol "AttachDynamicObjectToVehicle"
../gamemodes/OnCommand.pwn(8434) : error 017: undefined symbol "AttachDynamicObjectToVehicle"
../gamemodes/OnCommand.pwn(8439) : error 017: undefined symbol "AttachDynamicObjectToVehicle"
../gamemodes/OnCommand.pwn(8444) : error 017: undefined symbol "AttachDynamicObjectToVehicle"
../gamemodes/OnCommand.pwn(10420) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10420) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10420) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10426) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10426) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10426) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10538) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10538) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10538) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10542) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10542) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10542) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10829) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10829) : warning 202: number of arguments does not match definition
../gamemodes/OnCommand.pwn(10829) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(4942) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(4942) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(4942) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(7240) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(7251) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(15447) : error 017: undefined symbol "EditDynamicObject"
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(15545) : error 017: undefined symbol "EditDynamicObject"
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(15845) : error 017: undefined symbol "EditDynamicObject"
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(15944) : error 017: undefined symbol "EditDynamicObject"
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(16083) : error 017: undefined symbol "EditDynamicObject"
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(16148) : error 017: undefined symbol "EditDynamicObject"
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(19669) : warning 235: public function lacks forward declaration (symbol "OnPlayerEditDynamicObject")
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(19673) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(19673) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(19673) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(19839) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(19839) : warning 202: number of arguments does not match definition
C:\Users\User\Desktop\Roleplay\gamemodes\gamemode.pwn(19839) : warning 202: number of arguments does not match definition
Pawn compiler 3.2.3664	 	 	Copyright (c) 1997-2006, ITB CompuPhase


15 Errors.
Primeira Linha, 4942:
Code:
case 1: MoveDynamicObject(pdgate,1588.50806, -1637.89600, 14.60000, 2.0, 0.00000, 359.75000, 1.00000), PlaySoundInArea(1153,1589.021851, -1638.083862, 13.877514,20.0), gatedelay[pdgate] = 2;
SukMathcuck is offline   Reply With Quote
Old 09/11/2016, 07:45 PM   #7
SukMathcuck
Gangsta
 
SukMathcuck's Avatar
 
Join Date: Jun 2014
Posts: 646
Reputation: 2
Default Re: Colocando o gamemode para funcionar?

Ae pessoal, agora está dando dando o erro:
Quote:
[18:38:46] [debug] Run time error 19: "File or function is not found"
[18:38:46] [debug] Streamer_CallbackHook
[18:38:46] [debug] AttachDynamicObjectToVehicle
[18:38:46] [debug] EditDynamicObject
[18:38:46] [debug] Run time error 19: "File or function is not found"
[18:38:46] [debug] Streamer_CallbackHook
[18:38:46] [debug] AttachDynamicObjectToVehicle
[18:38:46] [debug] EditDynamicObject
[18:38:46] Script[gamemodes/AD-RP.amx]: Run time error 19: "File or function is not found"
[18:38:46] Number of vehicle models: 0
Por que isso? nada a ver? Qual include é essa?? Dynamic?

Alguem tem a include filesystem?
SukMathcuck is offline   Reply With Quote
Old 09/11/2016, 07:49 PM   #8
Magic11
Banned
 
Join Date: Oct 2015
Location: Brazil
Posts: 99
Reputation: 10
Default Re: Colocando o gamemode para funcionar?

Utilize a include streamer.
Magic11 is offline   Reply With Quote
Old 09/11/2016, 07:59 PM   #9
SukMathcuck
Gangsta
 
SukMathcuck's Avatar
 
Join Date: Jun 2014
Posts: 646
Reputation: 2
Default Re: Colocando o gamemode para funcionar?

Oolha isso, agora o pawn compiler tá parando de funcionar por que? Estou confuso com isso tudo..

Minhas includes:
Quote:
#include <a_samp>
#include <DOF2>
#include <dns>
#include <filesystem>
#include <Foreach>
#include <sscanf2>
#include <streamer>
#include <zcmd>
Eu acho que o problema está nas includes e principalmente nessa include filesystem, que não estou encontrando.
SukMathcuck is offline   Reply With Quote
Old 10/11/2016, 12:14 PM   #10
SukMathcuck
Gangsta
 
SukMathcuck's Avatar
 
Join Date: Jun 2014
Posts: 646
Reputation: 2
Default Re: Colocando o gamemode para funcionar?

Up! alguém tem as includes?

Quote:
#include <a_samp>
#include <DOF2>
#include <dns>
#include <filesystem>
#include <Foreach>
#include <sscanf2>
#include <streamer>
#include <zcmd>
Já atualizei a include streamer, não sei o que pode ser.
SukMathcuck is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Ajuda] colocando armas para player Natan_silva Português/Portuguese 11 16/09/2012 08:43 PM
[Ajuda] Colocando objetos com botão para ativar douglasmonteiro Português/Portuguese 12 09/04/2011 08:48 PM
[TUT]Colocando Org Policial Para Prender Quando Matar Vageto[STK] Português/Portuguese 15 19/02/2011 09:46 PM
[ajuda]Colocando Para Equipar e Entrar em interiores com o F Gabriel_Halls Português/Portuguese 7 25/08/2010 06:46 PM


All times are GMT. The time now is 11:06 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.