SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 13/10/2018, 08:46 PM   #1
Longover
Big Clucker
 
Join Date: Oct 2017
Location: Romania
Posts: 123
Reputation: 0
Thumbs down No Errors.

Hi.

My gamemode then is compiling i give no errors,but the gm is compiled in a .amx with 0 KB memory usage.
Why?
Attached Images
File Type: jpg bruh.jpg (191.0 KB, 17 views)
Longover is offline   Reply With Quote
Old 13/10/2018, 09:49 PM   #2
Boarden
Little Clucker
 
Boarden's Avatar
 
Join Date: Jun 2014
Location: Bongistan
Posts: 6
Reputation: 0
Default Re: No Errors.

Did the compiler (pawnocc.exe) crash during the compile? That usually has the same effect as that shown in the screenshot.
__________________
Boarden is offline   Reply With Quote
Old 13/10/2018, 09:52 PM   #3
Longover
Big Clucker
 
Join Date: Oct 2017
Location: Romania
Posts: 123
Reputation: 0
Default Re: No Errors.

Quote:
Originally Posted by Boarden View Post
Did the compiler (pawnocc.exe) crash during the compile? That usually has the same effect as that shown in the screenshot.
Not crashing.
Longover is offline   Reply With Quote
Old 13/10/2018, 11:21 PM   #4
Longover
Big Clucker
 
Join Date: Oct 2017
Location: Romania
Posts: 123
Reputation: 0
Default Re: No Errors.

Quote:
Originally Posted by Boarden View Post
Did the compiler (pawnocc.exe) crash during the compile? That usually has the same effect as that shown in the screenshot.
How to solve,PLEASE!
Longover is offline   Reply With Quote
Old 14/10/2018, 12:03 AM   #5
Boarden
Little Clucker
 
Boarden's Avatar
 
Join Date: Jun 2014
Location: Bongistan
Posts: 6
Reputation: 0
Default Re: No Errors.

Quote:
Originally Posted by Longover View Post
How to solve,PLEASE!
I don't know exactly, reason why I thought it could be a compiler issue is due to the lack of any output from the compiler and because when the compiler crashes 0kb files are generated.

Do you have previous versions of your script? If yes, do they still compile properly?

Have you made any major changes to the script since the last successful compile?
__________________
Boarden is offline   Reply With Quote
Old 14/10/2018, 01:38 AM   #6
Threshold
High-roller
 
Threshold's Avatar
 
Join Date: Nov 2012
Location: Australia
Posts: 3,034
Reputation: 519
Default Re: No Errors.

When I used to face these issues I would comment out 50% of my script. If the issue still occurred, I would comment out the other 50% of the script.

Once it compiled I knew the issue was within the area that I just commented out. Then I would comment out half of that area and continue until I had gotten it down to a manageable area of code. Eventually you'll find the block of code that is giving your compiler trouble.
__________________

SERVER.LVCNR.NET:7777
Threshold is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pawn Compiling errors, Errors and Line are inside [ +REP ] EgyptForLife Scripting Help 8 19/07/2014 08:26 PM
[S-HELP] Compiling errors, Errors and Lines inside. EgyptForLife Scripting Help 3 16/07/2014 07:56 PM
Class Errors: loose indentation (2 Errors) DerickClark Scripting Help 18 22/02/2014 08:01 PM
[ERRORS] Errors appear after adding a Gang System. ••• ĤÁĶÁM ••• Help Archive 17 27/10/2010 05:19 PM
Common compiling errors - READ BEFORE POSTING ERRORS Streetplaya Help Archive 0 23/01/2010 11:20 AM


All times are GMT. The time now is 07:13 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.