SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Plugin Development

Reply
 
Thread Tools Display Modes
Old 16/03/2009, 08:48 AM   #1
XPlatform
Big Clucker
 
Join Date: May 2008
Posts: 116
Reputation: 0
Default Server error...Plugin compilation related.

Hello,

Recently I've installed a new version of a Linux operating system on my pc.

I can compile the code I wrote without any problems, It gives my a .so as I need.

When I go to start the server I get this:

Code:
[00:37:39] Server Plugins
[00:37:39] --------------
[00:37:39] Loading plugin: MyPlugin.so
[00:37:39] Failed (plugins/MyPlugin.so: wrong ELF class: ELFCLASS64)
[00:37:39] Loaded 0 plugins.
I did a little ******-ing, and found that the problem may be my operating system. 64-bit?
So from that I tried compiling with -m64 but It didn't make a difference.

Any help will be greatly appreciated,
Thanks,

Stephen
XPlatform is offline   Reply With Quote
Old 15/11/2009, 12:28 PM   #2
Streetplaya
Gangsta
 
Join Date: Nov 2007
Posts: 603
Reputation: 1
Default Re: Server error...Plugin compilation related.

try -m32
Streetplaya is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error plugin mysql in Centos 5 (32Bits) super-sergio16 Server Support 0 13/06/2010 08:38 AM
Error Help [Compiling Plugin] Oyabun Help Archive 0 14/12/2009 01:58 AM
SA-MP server related buttons not working? Corey_Faure Client Support 2 27/10/2009 08:51 PM
plugin error: libcurl.so.4: cannot open shared object file... Cuarteir˛ns. Help Archive 6 01/09/2009 06:58 PM


All times are GMT. The time now is 03:54 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.