SA-MP Forums

Go Back   SA-MP Forums > Non-English > Languages > Русский/Russian

Reply
 
Thread Tools Display Modes
Old 13/05/2020, 11:30 AM   #1
bybyby
Little Clucker
 
bybyby's Avatar
 
Join Date: Dec 2018
Location: Узбекистан,Город Фергана
Posts: 20
Reputation: 0
Exclamation Проблемы с созданием машин

Здраствуйте у меня вмоде есть сток CreatVehicles в нём есть вот такой цикл

PHP Code:
    for(new 0sizeof(CarsInfo); i++)
    {
        if((
CarsInfo[i][vParkX] == 0.0 && CarsInfo[i][vParkY] == 0.0 && CarsInfo[i][vParkZ] == 0.0 && CarsInfo[i][vParkAngle] == 0.0) || CarsInfo[i][vOwned] == 0)
        {
                
                
BuyableCar[i] = CreateVehicle(CarsInfo[i][vModel], CarsInfo[i][vPosX], CarsInfo[i][vPosY], CarsInfo[i][vPosZ], CarsInfo[i][vAngle], -1, -1, -1);
                
// printf("aa");
        
}
        else 
//if(CarsInfo[i][vParkX] != 0.0 && CarsInfo[i][vParkY] != 0.0 && CarsInfo[i][vParkZ] != 0.0 && CarsInfo[i][vParkAngle] != 0.0 && CarsInfo[i][vOwned] == 1)
        
{
                
BuyableCar[i] = CreateVehicle(CarsInfo[i][vModel], CarsInfo[i][vParkX], CarsInfo[i][vParkY], CarsInfo[i][vParkZ], CarsInfo[i][vParkAngle], CarsInfo[i][vColorOne], CarsInfo[i][vColorTwo], -1);
        }
        
        if(
CarsInfo[i][vWorld] > 0)
        {
             
LinkVehicleToInterior(BuyableCar[i], 1); // Для гаража
            
SetVehicleVirtualWorld(BuyableCar[i], CarsInfo[i][vWorld]);
        }
        else
        {
            
LinkVehicleToInterior(BuyableCar[i], 0);
            
SetVehicleVirtualWorld(BuyableCar[i], CarsInfo[i][vWorld]);
        }
        if(
CarsInfo[i][vOwned] == 0CarsInfo[i][vLock] = 0;
        
gCarLock[i+1] = CarsInfo[i][vLock];
        
AddVehicleComponent (i+1CarsInfo[i][vKolesocar]);
        
AddVehicleComponent (i+1CarsInfo[i][vNitro]);
        
AddVehicleComponent (i+1CarsInfo[i][vGidra]);
        
ChangeVehiclePaintjob(i+1CarsInfo[i][vPokraska]);
        if (
CarsInfo[i][vSpoiler] != 0AddVehicleComponent (i+1CarsInfo[i][vSpoiler]);
        if (
CarsInfo[i][vBamper1] != 0AddVehicleComponent (i+1CarsInfo[i][vBamper1]);
        if (
CarsInfo[i][vBamper2] != 0AddVehicleComponent (i+1CarsInfo[i][vBamper2]);
        
ChangeVehicleColor(i+1CarsInfo[i][vColorOne], CarsInfo[i][vColorTwo]);
        
Fuell[i+1] = CarsInfo[i][vFuel];
        new 
vnumber[15];
        
format(vnumbersizeof(vnumber), "%s"CarsInfo[i][vNumber]);
        
SetVehicleNumberPlate(i+1vnumber);
    } 
А само проблема вот здесь:
PHP Code:
        if((CarsInfo[i][vParkX] == 0.0 && CarsInfo[i][vParkY] == 0.0 && CarsInfo[i][vParkZ] == 0.0 && CarsInfo[i][vParkAngle] == 0.0) || CarsInfo[i][vOwned] == 0)
        {
                
                >>>>>>
BuyableCar[i] = CreateVehicle(CarsInfo[i][vModel], CarsInfo[i][vPosX], CarsInfo[i][vPosY], CarsInfo[i][vPosZ], CarsInfo[i][vAngle], -1, -1, -1);
                
// printf("aa");
        

После этого цикла мод дальше не загружается а до него всё работает если убраю именно
PHP Code:
BuyableCar[i] = CreateVehicle(CarsInfo[i][vModel], CarsInfo[i][vPosX], CarsInfo[i][vPosY], CarsInfo[i][vPosZ], CarsInfo[i][vAngle], -1, -1, -1); 
всё работает

Помогите мне пж(
bybyby is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Проблема с созданием базы SQLite proSeryoga Русский/Russian 4 12/10/2014 06:01 PM
Удаление машин DEMON91052 Русский/Russian 9 17/08/2014 10:27 AM
покупка машин hillko Русский/Russian 12 31/03/2014 04:02 PM
Замена моделей машин mihan-888 Русский/Russian 1 02/12/2012 05:29 PM
Нужна помощь с созданием мультиязычного сервера [BF]Superman Русский/Russian 6 01/04/2011 02:21 AM


All times are GMT. The time now is 03:55 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.