SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 10/10/2012, 10:55 AM   #1
Majava
Little Clucker
 
Join Date: Dec 2010
Posts: 44
Reputation: 1
Default Vehicle menu doesn't work

I need help with this. I watched tutorial but i dont get it working No errors but it doesn't spawn cars.
Pastebin
Majava is offline   Reply With Quote
Old 10/10/2012, 11:06 AM   #2
denNorske
Gangsta
 
denNorske's Avatar
 
Join Date: Nov 2011
Location: Oslo, Norway
Posts: 789
Reputation: 95
Default Re: Vehicle menu doesn't work

Check all other scripts for the line

Code:
 public OnDialogResponse
And find if there is any script that says

Code:
 return 0;
at the end of it. If there are, tell here.
__________________
xSF source has been publicly released: Available on git (https://git.ducky.rocks/denNorske/xsf-official-gamemode)
Useful Racespawn generator: https://forum.sa-mp.com/showpost.php...postcount=3777
Get an overview over your map objects: Check it here!
denNorske is offline   Reply With Quote
Old 10/10/2012, 11:07 AM   #3
Riddick94
Banned
 
Join Date: Mar 2010
Location: Poland
Posts: 1,767
Reputation: 223
Default Re: Vehicle menu doesn't work

Your count of command is not '10' but '5' (including slash) so you need to change it. Secondly.. if it's an Filterscript.. put a 'return 0;' at the end of the OnDialogResponse callback.
Riddick94 is offline   Reply With Quote
Old 10/10/2012, 12:27 PM   #4
Majava
Little Clucker
 
Join Date: Dec 2010
Posts: 44
Reputation: 1
Default Re: Vehicle menu doesn't work

E: Now its working i changed listitem ids 0 1
Majava is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[FilterScript] [FS]Weapon Menu + Player Menu + Vehicle Menu! [Good For Stunt Server] AlexHitman Filterscripts 4 27/07/2014 08:34 PM
[Include] ***New*** [INC] tAxI's Vehicle Shop/Menu with XVM Menu and Modsaving cptnsausage Includes 57 06/06/2012 06:40 AM
Any menu doesnt work :/. Subwoofer Scripting Help 0 24/03/2012 06:32 PM
Vehicle menu doesn't work. biltong Help Archive 4 25/01/2010 04:31 PM
Menu trouble: Can't Enter Vehicle After Closing Menu Badger(new) Help Archive 4 17/05/2009 01:26 AM


All times are GMT. The time now is 12:30 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.