SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help > Discussion

Reply
 
Thread Tools Display Modes
Old 19/09/2012, 03:08 PM   #11
playbox12
High-roller
 
playbox12's Avatar
 
Join Date: Feb 2010
Location: Netherlands
Posts: 1,319
Reputation: 216
Default Re: "hidden" object ids added?

Nope using CreateObject does not work, tested. I'm curious though as to why you can add that object in the map editor but not in SAMP. Is this a scripted limitation or an engine limitation (like stewie said above)? It'd be neat if it'd be possible though.
playbox12 is offline   Reply With Quote
Old 19/09/2012, 03:11 PM   #12
SuperViper
High-roller
 
SuperViper's Avatar
 
Join Date: Sep 2011
Posts: 1,178
Reputation: 315
Default Re: "hidden" object ids added?

I tried this and the collision is there but it's invisible.
__________________
Release NameUse
FairPlayKeep the cheaters out of your server
Object Model ArrayArray of every single object model in the game
RCON PanelControl any server as you like with RCON controls
SlopeClimb up a steep hill against other players with cars falling down

I do not play on any SAMP server. Anyone with the name Ricky Phelps in-game is an imposter.
SuperViper is offline   Reply With Quote
Old 19/09/2012, 07:45 PM   #13
2KY
Gangsta
 
2KY's Avatar
 
Join Date: Jan 2012
Location: United States
Posts: 950
Reputation: 166
Default Re: "hidden" object ids added?

Quote:
Originally Posted by SuperViper View Post
I tried this and the collision is there but it's invisible.
That's.... odd. Hate when this kind of thing happens.
__________________
Check out my wiki page
2KY is offline   Reply With Quote
Old 19/09/2012, 08:52 PM   #14
Extremo
Gangsta
 
Extremo's Avatar
 
Join Date: Jul 2008
Posts: 717
Reputation: 90
Default Re: "hidden" object ids added?

Assuming ped and vehicle models are stored in the gta3 archive like anything else - they probably have extra files that most objects do not share. I obviously couldn't know for sure but if I had to code the CreateObject native - I'd of coded it the easiest way - which is assuming that every object has the same data and no more. So if you attempted to load a ped model that has more data than an object model - CreateObject would have nothing to detect this and would blatantly load garbage and expect that garbage to be proper data for use.

At least the symptoms remind me to how my Game Engine sometimes handles things. I of course can only assume here, only people who know how CreateObject exactly works could say what could of gone sideways here.

Regards.
__________________
Extremo is offline   Reply With Quote
Old 20/09/2012, 03:05 AM   #15
Backwardsman97
High-roller
 
Backwardsman97's Avatar
 
Join Date: Nov 2007
Posts: 1,501
Reputation: 36
Default Re: "hidden" object ids added?

Quote:
Originally Posted by ****** View Post
When you say "the black guy", WHICH black guy do you mean?
Hahaha
Backwardsman97 is offline   Reply With Quote
Old 29/09/2012, 05:26 PM   #16
Basssiiie
Gangsta
 
Basssiiie's Avatar
 
Join Date: Mar 2011
Location: The Netherlands
Posts: 758
Reputation: 191
Default Re: "hidden" object ids added?

GTA SA just has a giant list of models. That explains why you get a ped when you use id 14 in the Map Editor, because it's in the same model list as all the other objects.

The list is roughly:
0 to 300 = Ped models;
321 to 371 = Weapon models;
400 to 611 = Vehicle models;
~615 to ~18000 = Other object models.

Never noticed this? The SA-MP Map Editor just shows the model, that's why it's capable of showing ped models. But when you try spawning them in SA-MP itself, it can't be done. They have extra data which can't be read by CreateObject. (Like bones from peds, damage models from vehicles)
Basssiiie is offline   Reply With Quote
Old 25/10/2012, 09:39 PM   #17
SDraw
Gangsta
 
SDraw's Avatar
 
Join Date: Apr 2011
Location: Earth
Posts: 582
Reputation: 157
Default Re: "hidden" object ids added?

Yeah, I found that in MC in free time But in SA-MP I always get crash with these objects
__________________
GitHub
SDraw is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
5 Dialog errors - Input line too long, undefined symbol "t","is" and "only" Deal-or-die Scripting Help 6 01/05/2012 01:08 PM
"Hidden" paintjobs are not available anymore? Defrago Client Support 0 02/01/2012 08:49 AM
Admin script requires "ReturnUser", "strtok" and "IsNumeric" Rubennnnn Help Archive 1 02/12/2009 07:08 PM
"Bots", "AI", "NPCs"... Computer-controlled pedestrians and traffic! ssflsnoob General 2 23/11/2008 07:06 PM


All times are GMT. The time now is 11:34 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.