SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 08/04/2019, 09:10 PM   #1
Despare
Big Clucker
 
Join Date: Aug 2009
Posts: 110
Reputation: 0
Default Error: Function not registered: 'WP_Hash'

SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[15:05:39]
[15:05:39] Server Plugins
[15:05:39] --------------
[15:05:39] Loading plugin: audio
[15:05:39]

*** Audio Plugin v0.5 R2 by Incognito loaded ***

[15:05:39] Loaded.
[15:05:39] Loading plugin: sscanf
[15:05:39]

[15:05:39] ===============================

[15:05:39] sscanf plugin loaded.

[15:05:39] (c) 2009 Alex "******" Cole

[15:05:39] 0.3d-R2 500 Players "dnee"

[15:05:39] ===============================

[15:05:39] Loaded.
[15:05:39] Loading plugin: streamer
[15:05:39]

*** Streamer Plugin v2.6.1 by Incognito loaded ***

[15:05:39] Loaded.
[15:05:39] Loading plugin: nativechecker
[15:05:39] Loaded.
[15:05:39] Loaded 4 plugins.

[15:05:39]
[15:05:39] Filterscripts
[15:05:39] ---------------
[15:05:39] Loading filterscript 'christmas.amx'...
[15:05:39] Loading filterscript 'anims.amx'...
[15:05:39] Loading filterscript 'yom_buttons.amx'...
[15:05:39] Loaded 3 filterscripts.

[15:05:40] Error: Function not registered: 'WP_Hash'
[15:05:40] Script[gamemodes/HorizonRoleplay.amx]: Run time error 19: "File or function is not found"
[15:05:40] Number of vehicle models: 0


Quote:
[15:05:40] Error: Function not registered: 'WP_Hash'
Need some help with this error,
Despare is offline   Reply With Quote
Old 08/04/2019, 09:16 PM   #2
polygxn
Banned
 
Join Date: Dec 2018
Posts: 100
Reputation: 21
Default Re: Error: Function not registered: 'WP_Hash'

If you have a nativechecker plugin then put it in the last place in your server.cfg. Its probably just a false error. If not, just copy this anywhere in your GM:
pawn Code:
native WP_Hash(buffer[], len, const str[]);
polygxn is offline   Reply With Quote
Old 08/04/2019, 09:21 PM   #3
Despare
Big Clucker
 
Join Date: Aug 2009
Posts: 110
Reputation: 0
Default Re: Error: Function not registered: 'WP_Hash'

Quote:
Originally Posted by polygxn View Post
If you have a nativechecker plugin then put it in the last place in your server.cfg. Its probably just a false error. If not, just copy this anywhere in your GM:
pawn Code:
native WP_Hash(buffer[], len, const str[]);
I have the native of WP_Hash already in the script, and I was able to compile the .pwn without any errors but when i started the server it had popped up with that error.
Despare is offline   Reply With Quote
Old 08/04/2019, 09:43 PM   #4
Despare
Big Clucker
 
Join Date: Aug 2009
Posts: 110
Reputation: 0
Default Re: Error: Function not registered: 'WP_Hash'

Quote:
Originally Posted by polygxn View Post
If you have a nativechecker plugin then put it in the last place in your server.cfg. Its probably just a false error. If not, just copy this anywhere in your GM:
pawn Code:
native WP_Hash(buffer[], len, const str[]);
Quote:
Originally Posted by ****** View Post
Compiling and running aren't the same thing. You need the include (which you have) and the plugin (which you don't).
The whirlpool plugin correct? I just included the whirlpool in the plugins, but it seemed to closes the samp-server.exe saying this in the server log


SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[15:41:47]
[15:41:47] Server Plugins
[15:41:47] --------------
[15:41:47] Loading plugin: audio
[15:41:47]

*** Audio Plugin v0.5 R2 by Incognito loaded ***

[15:41:47] Loaded.
[15:41:47] Loading plugin: sscanf
[15:41:47]

[15:41:47] ===============================

[15:41:47] sscanf plugin loaded.

[15:41:47] (c) 2009 Alex "******" Cole

[15:41:47] 0.3d-R2 500 Players "dnee"

[15:41:47] ===============================

[15:41:47] Loaded.
[15:41:47] Loading plugin: streamer
[15:41:47]

*** Streamer Plugin v2.6.1 by Incognito loaded ***

[15:41:47] Loaded.
[15:41:47] Loading plugin: whirlpool
[15:41:54]
[15:41:54] ==================
[15:41:54]
[15:41:54] Whirlpool loaded
[15:41:54]
[15:41:54] ==================
[15:41:54]
[15:41:54] Loaded.
[15:41:54] Loaded 4 plugins.

[15:41:54]
[15:41:54] Filterscripts
[15:41:54] ---------------
[15:41:54] Loading filterscript 'christmas.amx'...
[15:41:54] Loading filterscript 'anims.amx'...
[15:41:54] Loading filterscript 'yom_buttons.amx'...
[15:41:54] Loaded 3 filterscripts.

[15:41:54]
[15:41:54] =======================================
[15:41:54] | |
[15:41:54] | YSI version 1.03.0011 |
[15:41:54] | By Alex "******" Cole |
[15:41:54] | |
[15:41:54] | Checking the latest YSI version.. |
[15:41:54] | |
[15:41:54] =======================================
[15:41:54]
Despare is offline   Reply With Quote
Old 08/04/2019, 09:47 PM   #5
Logic_
Banned
 
Join Date: Jun 2015
Posts: 1,506
Reputation: 305
Default Re: Error: Function not registered: 'WP_Hash'

Your SSCANF plugin is outdated.
Logic_ is offline   Reply With Quote
Old 08/04/2019, 09:53 PM   #6
Despare
Big Clucker
 
Join Date: Aug 2009
Posts: 110
Reputation: 0
Default Re: Error: Function not registered: 'WP_Hash'

Quote:
Originally Posted by Logic_ View Post
Your SSCANF plugin is outdated.
Where can I find the most recent updated sscanf
Despare is offline   Reply With Quote
Old 08/04/2019, 10:57 PM   #7
Crayder
Banned
 
Join Date: Sep 2013
Location: Flames of Hell
Posts: 3,324
Reputation: 652
Default Re: Error: Function not registered: 'WP_Hash'

https://github.com/maddinat0r/sscanf
https://forum.sa-mp.com/showthread.php?t=570927

Also, your YSI is outdated... YEARS AGO. Are you trying to use an old gamemode?
Crayder is offline   Reply With Quote
Old 09/04/2019, 04:51 AM   #8
Despare
Big Clucker
 
Join Date: Aug 2009
Posts: 110
Reputation: 0
Default Re: Error: Function not registered: 'WP_Hash'

Quote:
Originally Posted by Crayder View Post
https://github.com/maddinat0r/sscanf
https://forum.sa-mp.com/showthread.php?t=570927

Also, your YSI is outdated... YEARS AGO. Are you trying to use an old gamemode?
Yeah it looks like YSI is way outdated and yeah i'm trying to use an old gamemode.
Despare is offline   Reply With Quote
Old 09/04/2019, 06:55 AM   #9
Crayder
Banned
 
Join Date: Sep 2013
Location: Flames of Hell
Posts: 3,324
Reputation: 652
Default Re: Error: Function not registered: 'WP_Hash'

Quote:
Originally Posted by Despare View Post
Yeah it looks like YSI is way outdated and yeah i'm trying to use an old gamemode.
You'll have much better luck just using a newer gamemode or making your own from scratch. Keep in mind, making your own may seem scary, but it's so much better. Don't go for a high number of lines, go for simplicity and clean scripting. Get your ideas from these older gamemodes, but you'll actually know what they do if you implement them yourself.

Chances are, the gamemode you are using right now is completely outdated and is probably horribly inefficient.

Just a recommendation. I started where you are. Once you learn a little about scripting it is so much more fun to just do things on your own.
Crayder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error : Function not registered WP_Hash lwilson Scripting Help 2 25/05/2016 02:36 PM
[Error] Function not registered: 'WP_Hash' LuKkY Scripting Help 16 24/07/2015 07:32 PM
Error: Function not registered: 'WP_Hash' Antoniohl Scripting Help 14 28/04/2015 04:56 PM
Error: Function not registered: 'WP_Hash' Arnold_Collins Scripting Help 6 30/03/2015 01:55 PM
Error: Function not registered: 'WP_Hash Ryan McDuff Server Support 5 17/02/2014 08:04 AM


All times are GMT. The time now is 11:22 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.