SA-MP Forums

Go Back   SA-MP Forums > SA-MP Server > Server Support

Reply
 
Thread Tools Display Modes
Old 31/07/2019, 08:05 PM   #1
kukboy
Big Clucker
 
kukboy's Avatar
 
Join Date: Nov 2018
Posts: 61
Reputation: 3
Default Server Lag

Hi guys, While entering and exiting there is lag, I don't what causes that lag I'm using MySQL. It's not just entering and exiting there is lag sometimes while players are having a gun fight.
__________________
Paradise City Roleplay

IP: samp.paradisecityroleplay:7777
Discord: https://discord.gg/fC8srfw[/



-----------------------------------
kukboy is offline   Reply With Quote
Old 01/08/2019, 10:02 PM   #2
willttoonn
Gangsta
 
willttoonn's Avatar
 
Join Date: Nov 2011
Location: Brazil
Posts: 871
Reputation: 62
Default Re: Server Lag

You host is onlyone or coletive host? If onlyone, check your VPS settings. If you system is linux use htop to check the hardware consume. If is coletive proced to otimizations.

If the hardware consume is high try to otimize your gamemode.

1. Transform your OnPlayerUpdate to one Timer with 1 second;
2. Change the interval of timers with same miliseconds.
  • E.g.
    Now: Timer 1 = 1000, Timer 2 = 1000 and Timer 3 = 1000;
    Changed: Timer 1 = 1000, Timer 2 = 1050 and Timer 3 = 1100.
3. If you have any auto-save to save player online, put this auto-save to execute every five minutes.
__________________
Sometimes a captain has to make the unpopular call because that's his responsibility
willttoonn is offline   Reply With Quote
Old 05/08/2019, 09:46 PM   #3
kukboy
Big Clucker
 
kukboy's Avatar
 
Join Date: Nov 2018
Posts: 61
Reputation: 3
Default Re: Server Lag

Thanks, I just optimised OnPlayerUpdate.
__________________
Paradise City Roleplay

IP: samp.paradisecityroleplay:7777
Discord: https://discord.gg/fC8srfw[/



-----------------------------------
kukboy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Script works fine on developer's server, but not on the main public server. Shetch Scripting Help 1 20/06/2015 08:56 PM
Hosting Free server or make server online to Internet list dawoodshah Server Support 9 10/06/2015 10:22 PM
Every script I load, my server doesnt respond [+starting server need helpers] Cato Scripting Help 12 27/07/2013 05:42 PM
[FilterScript] Server Message [SERVER TIPS, SERVER MESSAGE OF THE DAY] - Simple, basic but editable! roar Filterscripts 10 28/02/2013 02:19 PM
[SERVER] Unable to continue, the server's bind doesn't match the defined one.? robert4049 Server Support 9 12/07/2010 04:31 AM


All times are GMT. The time now is 01:18 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.