SA-MP Forums

Go Back   SA-MP Forums > SA-MP > General

Closed Thread
 
Thread Tools Display Modes
Old 01/01/2009, 05:14 AM   #1
JonathanSmith
Little Clucker
 
Join Date: Jan 2009
Posts: 1
Reputation: 0
Default 0.2X - Linux ;]

Hello!

I have a serious problem ;] My Internet connection doesn't work on Windows [ heh, i don't know why xD ], so i am working on Ubuntu.

I have SAMP 0.2X and GTA:SA on my Linux Desktop. On WINE everything is working, but I cant execute gta_sa.exe from SAMP when I want to connect to the server...

It's like that: Clikcing on server, clicking "connect" and... nothing.

And my question is: How to open gta_sa.exe from SAMP on WINE...?

GTA:SA is working nicely on newest WINE and latest nVidia drivers for Linux. SAMP... not bad, but when I'm closing program it causes many, many errors, so I must restart deamon ;]

any suggestions for me?

BTW: Sorry for my English - It's not my most used language
JonathanSmith is offline  
Old 01/01/2009, 06:46 AM   #2
bzuco
Big Clucker
 
Join Date: Jan 2007
Posts: 77
Reputation: 0
Default Re: 0.2X - Linux ;]

you cantīt run sa-mp on linux
bzuco is offline  
Old 01/01/2009, 07:03 AM   #3
JaTochNietDan
High-roller
 
JaTochNietDan's Avatar
 
Join Date: Apr 2007
Location: Republic of Ireland
Posts: 2,502
Reputation: 363
Default Re: 0.2X - Linux ;]

Quote:
Originally Posted by bzuco
you cantīt run sa-mp on linux
Wine emulates almost all of the windows programs.

Sorry I don't know a solution though.
__________________
Releases:
[Includes]: [jBan] | [jBanLite]
[Plugins]: [FileManager] | [Execute]
[Applications]: [Remote Administrator *NEW] | [Script King] | [RCON GUI]
JaTochNietDan is offline  
Old 01/01/2009, 07:25 AM   #4
Mikep
High-roller
 
Join Date: Apr 2008
Posts: 1,042
Reputation: 10
Default Re: 0.2X - Linux ;]

Wine? lol

Linux sucks imo, Windows ftw
Mikep is offline  
Old 01/01/2009, 07:30 AM   #5
bzuco
Big Clucker
 
Join Date: Jan 2007
Posts: 77
Reputation: 0
Default Re: 0.2X - Linux ;]

Quote:
Originally Posted by JaTochNietDan
Quote:
Originally Posted by bzuco
you cantīt run sa-mp on linux
Wine emulates almost all of the windows programs.

Sorry I don't know a solution though.
but kye blocked d3d injects or something else i donīt remember....
bzuco is offline  
Old 01/01/2009, 08:59 AM   #6
Nummi
Little Clucker
 
Join Date: Oct 2008
Posts: 11
Reputation: 0
Default Re: 0.2X - Linux ;]

Quote:
Originally Posted by Mikep
Wine? lol

Linux sucks imo, Windows ftw
My dear, Linux wins.

Anyway, ask for help on Wine's forum
Nummi is offline  
Old 01/01/2009, 09:28 AM   #7
sebihunter
Huge Clucker
 
Join Date: Nov 2006
Posts: 305
Reputation: 3
Default Re: 0.2X - Linux ;]

You canīt use SA-MP on Linux with WINE. Itīs blocked by Kye (d3d9 injection was abused by cheaters)
sebihunter is offline  
Old 01/01/2009, 10:44 AM   #8
KingJ
Huge Clucker
 
Join Date: Feb 2008
Location: UK
Posts: 365
Reputation: 64
Default Re: 0.2X - Linux ;]

Sorry, you can't run 0.2X under Wine due to a protection mechanism to help protect cheating. Due to the way Wine runs it triggers this protection mechanism and quits.
__________________
KINGJ.NET Game Servers is now owned by SmartBytes LLC. Click here for more information!
KingJ is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
samp linux server 03r5 doesn't run on 64 bits linux edelcat Server Support 2 08/09/2010 09:22 AM
Linux Nee Everything and Nothing 1 15/06/2010 09:40 AM
SA:MP and linux Pwnzor Client Support 2 01/04/2010 09:46 PM
Request to a Linux specialist:From Windows to Linux Thomas_Ahmey Help Archive 1 19/02/2010 11:37 AM
Linux [LNL]Remulis Server Support 3 15/11/2009 12:27 PM


All times are GMT. The time now is 08:13 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.