SA-MP Forums

Go Back   SA-MP Forums > SA-MP Server > Server Support

Reply
 
Thread Tools Display Modes
Old 05/05/2018, 07:24 PM   #1
Error1337
Little Clucker
 
Error1337's Avatar
 
Join Date: May 2018
Location: Chisinau
Posts: 6
Reputation: 0
Default Getting Error: function not registered.

!!I am a noob!!Hi guys, so when i'm trying to run my server, i'm getting an error.
I know there's a lot of threads with the same problem, but the solutions don't work for me
Logs: (At the end)

HTML Code:
----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[20:49:11] weburl = "www.sa-mp.com"  (string)
[2018-05-05 20:49:11] 
[2018-05-05 20:49:11] Server Plugins
[2018-05-05 20:49:11] --------------
[2018-05-05 20:49:11]  Loading plugin: crashdetect.so
[2018-05-05 20:49:11]   CrashDetect plugin 4.19
[2018-05-05 20:49:11]   Loaded.
[2018-05-05 20:49:11]  Loading plugin: streamer.so
[2018-05-05 20:49:11] 

*** Streamer Plugin v2.8.2 by Incognito loaded ***

[2018-05-05 20:49:11]   Loaded.
[2018-05-05 20:49:11]  Loading plugin: mysql_static.so
[2018-05-05 20:49:11]  >> plugin.mysql: R39-2 successfully loaded.
[2018-05-05 20:49:11]   Loaded.
[2018-05-05 20:49:11]  Loading plugin: whirlpool.so
[2018-05-05 20:49:11]  
[2018-05-05 20:49:11]  ==================
[2018-05-05 20:49:11]  
[2018-05-05 20:49:11]   Whirlpool loaded
[2018-05-05 20:49:11]  
[2018-05-05 20:49:11]  ==================
[2018-05-05 20:49:11]  
[2018-05-05 20:49:11]   Loaded.
[2018-05-05 20:49:11]  Loading plugin: sscanf.so
[2018-05-05 20:49:11] 

[2018-05-05 20:49:11]  ===============================

[2018-05-05 20:49:11]       sscanf plugin loaded.     

[2018-05-05 20:49:11]          Version:  2.8.2        

[2018-05-05 20:49:11]    (c) 2012 Alex "Y_Less" Cole  

[2018-05-05 20:49:11]  ===============================

[2018-05-05 20:49:11]   Loaded.
[2018-05-05 20:49:11]  Loading plugin: dc_cmd.so
[2018-05-05 20:49:11]   Daniel''s CMD plugin v2.01
[2018-05-05 20:49:11]   Loaded.
[2018-05-05 20:49:11]  Loading plugin: regex.so
[2018-05-05 20:49:11] 

[2018-05-05 20:49:11] ______________________________________

[2018-05-05 20:49:11]  Regular Expression Plugin v0.2.1 loaded
[2018-05-05 20:49:11] ______________________________________

[2018-05-05 20:49:11]  By: Fro (c) Copyright <TBG> 2009-2011
[2018-05-05 20:49:11] ______________________________________

[2018-05-05 20:49:11]   Loaded.
[2018-05-05 20:49:11]  Loading plugin: nativechecker.so
[2018-05-05 20:49:11]   Loaded.
[2018-05-05 20:49:11]  Loaded 8 plugins.

[2018-05-05 20:49:11] 
[2018-05-05 20:49:11] Filterscripts
[2018-05-05 20:49:11] ---------------
[2018-05-05 20:49:11]   Loaded 0 filterscripts.

[2018-05-05 20:49:11] AMX (167119832) loaded
[2018-05-05 20:49:11]    Error: Function not registered: 'DC_CMD_Init'
[2018-05-05 20:49:11]    Error: Function not registered: 'FO_SetMode'
[2018-05-05 20:49:11]    Error: Function not registered: 'FO_SetValue'
[2018-05-05 20:49:11] [debug] Run time error 19: "File or function is not found"
[2018-05-05 20:49:11] [debug]  DC_CMD_Init
[2018-05-05 20:49:11] [debug]  FO_SetMode
[2018-05-05 20:49:11] [debug]  FO_SetValue
[2018-05-05 20:49:11] [debug] Run time error 19: "File or function is not found"
[2018-05-05 20:49:11] [debug]  DC_CMD_Init
[2018-05-05 20:49:11] [debug]  FO_SetMode
[2018-05-05 20:49:11] [debug]  FO_SetValue
[2018-05-05 20:49:11] Script[gamemodes/skyland.amx]: Run time error 19: "File or function is not found"
[2018-05-05 20:49:11] Number of vehicle models: 0
Error1337 is offline   Reply With Quote
Old 06/05/2018, 12:33 PM   #2
StefaNO [ITA]
Big Clucker
 
Join Date: Apr 2009
Posts: 52
Reputation: 10
Default Re: Getting Error: function not registered.

Can you post your server.cfg?
StefaNO [ITA] is offline   Reply With Quote
Old 06/05/2018, 03:50 PM   #3
Error1337
Little Clucker
 
Error1337's Avatar
 
Join Date: May 2018
Location: Chisinau
Posts: 6
Reputation: 0
Default Re: Getting Error: function not registered.

Quote:
Originally Posted by StefaNO [ITA] View Post
Can you post your server.cfg?
I solved every thing, but i'm getting a new error in mysql logs:
HTML Code:
[17:48:33] [WARNING] cache_get_data - no active cache
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('18')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('18')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('18')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('18')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('18')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('18')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('18')
[17:48:33] [ERROR] cache_get_field_content_int - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('18')
[17:48:33] [ERROR] cache_get_field_content_int - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('9')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('9')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('9')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('9')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('9')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('9')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('9')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('13')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('13')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('13')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('13')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('13')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
[17:48:33] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('13')
[17:48:33] [ERROR] cache_get_field_content_float - invalid datatype
Error1337 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error: Function not registered: 'WP_Hash' & Run time error 19: "File or function is not found" Dorito Server Support 5 06/09/2018 09:19 AM
Error: Function not registered: AlexanderChwojewski SA-MP 0.3.DL 2 31/03/2018 03:50 PM
Runtime error 19 file or function not found and Error: Function not registered Alpha000 Server Support 1 14/12/2014 11:12 AM
Error: Function not registered FalconeX Scripting Help 1 13/04/2013 01:56 PM
Registered plate stock error 'error 076: syntax error in the expression, or invalid function call' Deal-or-die Scripting Help 2 25/06/2012 04:12 PM


All times are GMT. The time now is 10:02 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.