SA-MP Forums

Go Back   SA-MP Forums > Non-English > Languages > Português/Portuguese

Reply
 
Thread Tools Display Modes
Old 12/02/2020, 02:19 AM   #1
NWDMadara
Gangsta
 
NWDMadara's Avatar
 
Join Date: Mar 2018
Posts: 511
Reputation: 16
Default Problema AMX

Boa Noite

Estou enfrentando alguns problemas em relação ao tamanho do amx e gostaria da ajuda de vocês.


É o seguinte: Hoje fui atualizar a biblioteca YSI, e ao fazer isso, percebi um aumento significativo no tamanho do .AMX, de 250kb ele foi para 11.2mb.

Creio que seja diretamente um conflito com o Zeex Compiler, aqui vai alguns adendos:

• Eu já testei a biblioteca em si, removendo a definição dela (Por hora eu estou usando apenas o y_iterator)
• Com a versão original do compilador fica tudo normal, o AMX acaba ficando até muito mais leve, com seus 70kbs (Antes eles ficava com 250~ na versão 3.10.9 do Zeex e com a biblioteca YSI) porém demora muito para compilar, cerca de 20s mesmo com os seus 70kb.
• A versão 4 do YSI está normal
• Eu testei algumas versões do Zeex, da 3.10.6 até a 3.10.10 e todas dão a mesma coisa.


Já aconteceu com algum de vocês, alguém teria uma ideia do que poderia ser, ou poderiam me passar o download de tudo normalizado e atualizado?

De preferência eu gostaria de saber o caroço nesse angu, pois já estou há mais de 2 horas no troca-troca de arquivos e testes.
NWDMadara is offline   Reply With Quote
Old 12/02/2020, 05:15 AM   #2
Eiss
Little Clucker
 
Eiss's Avatar
 
Join Date: Jul 2019
Location: /bin/
Posts: 12
Reputation: 15
Default Re: Problema AMX

Você atualizou para qual versão do YSI?
Caso não esteja fazendo uso da versão 5.x, aconselho usá-la.

O tamanho do AMX é insignificante.
__________________
Eiss is offline   Reply With Quote
Old 12/02/2020, 11:08 AM   #3
NWDMadara
Gangsta
 
NWDMadara's Avatar
 
Join Date: Mar 2018
Posts: 511
Reputation: 16
Default Re: Problema AMX

A release mais atual, 5. alguma coisa

Ao mesmo tempo que eu quero resolver isso logo eu quero deixar tudo nos trinques saca? Deixar tudo atualizado. Eu usava a YSI 5x mas eu acho que era outra release, e funcionava normal.

Por hora eu vou usar a YSI 4.x enquanto aguardo respostas..
NWDMadara is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 01:36 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.