SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 06/07/2012, 10:26 PM   #1
backnot
Little Clucker
 
Join Date: Nov 2011
Posts: 42
Reputation: 0
Default *UPDATE* Help with 1 RP problem *UPDATE*

1st: Can somebody convert me LSLRP to 0.3e version. -http://forum.sa-mp.com/showthread.php?t=123726&highlight=lslrp

2nd : I have 1 rp mod , but the passwords in /scriptfiles/FirstName_Lastname of the account are hashed .
I men my password for example is sec191 , in the file is Key=cweuMPQP .

Somebody , help me ?
tnx in advance

Leave them .
See this


I downloaded new mod ...
The passwords are hashed again ..
This time is not so easy , there is no "encrypt" tag in the gamemode .
It's using Dini . here is only "hash" tags .
IF i delete them its giving me errors and warnings . I must make the register form to not hash passwords.
Here are the codes...

Quote:
if (dialogid == 1)
{
new name[MAX_PLAYER_NAME], file[256];
GetPlayerName(playerid, name, sizeof(name));
format(file, sizeof(file), USERS_FILES, name);
if(!response) return Kick(playerid);
if (!strlen(inputtext)) return
ShowPlayerDialog(playerid, 1, DIALOG_STYLE_INPUT, "Hi your not registered", "Welcome, your not registered mate, input your registration pw below", "Register", "Leave");
dini_Create(file);
dini_IntSet(file, "Password", PlayerInfo[playerid][pKey] = udb_hash(inputtext));
Quote:
if (dialogid == 2)
{
new name[MAX_PLAYER_NAME], file[256];
GetPlayerName(playerid, name, sizeof(name));
format(file, sizeof(file), USERS_FILES, name);
if(!response) return Kick(playerid);
if (!strlen(inputtext)) return ShowPlayerDialog(playerid, 2, DIALOG_STYLE_INPUT, "Welcome to Intelexe's Role Play", "SERVER:You have 60 seconds to Login\nHINT:Visit us on Our Website!", "Login", "Leave");
new tmp;
tmp = dini_Int(file, "Password");
if(udb_hash(inputtext) != tmp)

{
SendClientMessage(playerid, COLOR_RED, "Wrong PW sir.");
ShowPlayerDialog(playerid, 2, DIALOG_STYLE_INPUT, "Welcome to Intelexe's Role Play", "SERVER:You have 60 seconds to Login\nHINT:Visit us on Our Website!", "Login", "Leave");
return 1;
}
gPlayerLogged[playerid] = 1;
OnPlayerLogin(playerid, inputtext);
}

Last edited by backnot; 07/07/2012 at 01:43 PM.
backnot is offline   Reply With Quote
Old 06/07/2012, 10:30 PM   #2
.FuneraL.
High-roller
 
.FuneraL.'s Avatar
 
Join Date: Feb 2012
Location: Pawno.exe
Posts: 2,081
Reputation: 146
Default Re: Help with 2 RP problems

Quote:
Originally Posted by backnot View Post
1st: Can somebody convert me LSLRP to 0.3e version. -http://forum.sa-mp.com/showthread.php?t=123726&highlight=lslrp

2nd : I have 1 rp mod , but the passwords in /scriptfiles/FirstName_Lastname of the account are hashed .
I men my password for example is sec191 , in the file is Key=cweuMPQP .

Somebody , help me ?
tnx in advance
Download the Includes / Server 0.3e on the official website of the samp and change your folder pawno.
According to what you said about the registration system, you can try swapping the hash's for strval (inputText) do not want to leave the encrypted passwords.
.FuneraL. is offline   Reply With Quote
Old 06/07/2012, 10:31 PM   #3
coole210
Gangsta
 
Join Date: Jul 2008
Location: Canada
Posts: 995
Reputation: 84
Default Re: Help with 2 RP problems

1. You can simply convert it by downloading a 0.3e server, opening the pawno for it, opening the PWN file with it, then compiling it.

2. Passwords are hashed for a reason, so you don't know the passwords, and more importantly so anybody who has access to your files don't know the password. You can simply remove the hash system from the script, though.
coole210 is offline   Reply With Quote
Old 06/07/2012, 10:39 PM   #4
backnot
Little Clucker
 
Join Date: Nov 2011
Posts: 42
Reputation: 0
Default Re: Help with 2 RP problems

1. I'm doing it , but is giving me error . On 0.3d it's working perfectly . On 0.3e is giving me this error :
SA-MP Dedicated Server
----------------------
v0.3e, (C)2005-2012 SA-MP Team

[00:30:18] filterscripts = "" (string)
[00:30:18]
[00:30:18] Server Plugins
[00:30:18] --------------
[00:30:18] Loading plugin: streamer
[00:30:18]

*** Streamer Plugin v2.3.3 by Incognito loaded ***


[00:30:18] Loaded.
[00:30:18] Loaded 1 plugins.

[00:30:18]
[00:30:18] Filterscripts
[00:30:18] ---------------
[00:30:18] Loaded 0 filterscripts.

[00:30:18] Script[gamemodes/lslrp.amx]: Run time error 19: "File or function is not found"
[00:30:18] Number of vehicle models: 0



2. I'll host server and there will be a lot of hackers , crackers , etc. So I must know the passwords.
And how I can remove it ?
backnot is offline   Reply With Quote
Old 06/07/2012, 10:42 PM   #5
coole210
Gangsta
 
Join Date: Jul 2008
Location: Canada
Posts: 995
Reputation: 84
Default Re: Help with 2 RP problems

Just from what I see, the streamer plugin is not up-to-date, you must download the 0.3e version. You can double-check my theory by seeing what CRASHDETECT tells you (download crashdetect plugin from plugins section).
coole210 is offline   Reply With Quote
Old 06/07/2012, 10:53 PM   #6
backnot
Little Clucker
 
Join Date: Nov 2011
Posts: 42
Reputation: 0
Default Re: Help with 2 RP problems

I was looking for this streamer long time.
Now i have to to it again .
I'll , but if u have url 4 download it would be great ^^ .


The 2nd problem is still waiting 4 solution . How to fix the hashed password / sorry im newbie / .
backnot is offline   Reply With Quote
Old 06/07/2012, 10:55 PM   #7
Steven82
High-roller
 
Join Date: Nov 2009
Posts: 2,431
Reputation: 186
Default Re: Help with 2 RP problems

Quote:
Originally Posted by backnot View Post
I was looking for this streamer long time.
Now i have to to it again .
I'll , but if u have url 4 download it would be great ^^ .


The 2nd problem is still waiting 4 solution . How to fix the hashed password / sorry im newbie / .
Why are you going to un-hash passwords? Probably one of the stupidest things you could do to stop "hackers" as you stated above.
__________________
If you read my old posts; I apologize in advance.
Steven82 is offline   Reply With Quote
Old 06/07/2012, 11:10 PM   #8
backnot
Little Clucker
 
Join Date: Nov 2011
Posts: 42
Reputation: 0
Default Re: Help with 2 RP problems

Quote:
Originally Posted by Steven82 View Post
Why are you going to un-hash passwords? Probably one of the stupidest things you could do to stop "hackers" as you stated above.
Because 1/2 of my players will be kids under 13 years . They are ... uhmm stupid and will forget their passwords . Also if some hackers log into admins accounts or players accounts i must see the NEW password from /scriptfiles . There are a lot of other reasons ..
backnot is offline   Reply With Quote
Old 06/07/2012, 11:22 PM   #9
backnot
Little Clucker
 
Join Date: Nov 2011
Posts: 42
Reputation: 0
Default Re: Help with 2 RP problems

0kay .. I downloaded the new streamer v6 . Now i got this :

----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3e, (C)2005-2012 SA-MP Team

[16:32:30] filterscripts = "" (string)
[16:32:30]
[16:32:30] Server Plugins
[16:32:30] --------------
[16:32:30] Loading plugin: streamer
[16:32:30]

*** Streamer Plugin v2.6.1 by Incognito loaded ***

[16:32:30] Loaded.
[16:32:30] Loaded 1 plugins.

[16:32:30]
[16:32:30] Filterscripts
[16:32:30] ---------------
[16:32:30] Loaded 0 filterscripts.

[16:32:30] *** Streamer Plugin: Include file version (0) does not match plugin version (0x26104) (script needs to be recompiled with the latest include file)
[16:32:30] *** Streamer Plugin: Obsolete or invalid native found (script needs to be recompiled with the latest include file)
[16:32:30] Script[gamemodes/lslrp.amx]: Run time error 19: "File or function is not found"
[16:32:30] Number of vehicle models: 0
[16:33:03] --- Server Shutting Down.
[16:33:03]

*** Streamer Plugin v2.6.1 by Incognito unloaded ***
backnot is offline   Reply With Quote
Old 07/07/2012, 12:03 AM   #10
backnot
Little Clucker
 
Join Date: Nov 2011
Posts: 42
Reputation: 0
Default Re: Help with 2 RP problems

I fixed my 2nd problem .
HOW ? I deleted all "Encrypt" tags from my gamemode .

1st problem is not fixed . / still waiting /

tnx to alll.
backnot is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
So much problems Urefeu Help Archive 1 13/07/2011 08:50 PM
[”HELP!]Problems with NPC TiNcH010 Help Archive 2 06/07/2011 09:07 PM
2 Problems!! Hamza' Help Archive 2 28/09/2010 07:13 PM
[HELP]Some Problems Jo1Nt Help Archive 0 28/12/2009 12:03 AM
[FS]CarOwnership problems, GM Problems coole210 Help Archive 8 17/06/2009 09:27 PM


All times are GMT. The time now is 12:18 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.