SA-MP Forums

Go Back   SA-MP Forums > Non-English > Languages > Português/Portuguese

Reply
 
Thread Tools Display Modes
Old 03/03/2013, 01:17 AM   #1
-GooGle-
Huge Clucker
 
-GooGle-'s Avatar
 
Join Date: Dec 2010
Posts: 269
Reputation: 6
Default Não está criando o carro,comando /veh

Galera,oque está de errado nesse comando?Ele não está criando o carro :/


pawn Code:
CMD:veh(playerid, params[])
{
    new cor1,cor2,Veh;
    if (sscanf(params, "us",id,cor1,cor2))
    {
        SendClientMessage(playerid, -1, "Use: /ir [id] [cor 1] [cor 2]");
    }
    else
    {
        if (Admin[playerid] == 0) return SendClientMessage(playerid, 2, "Você não é Admin!");
        new pp[128],Float:X,Float:Y,Float:Z;
        GetPlayerPos(playerid,X,Y,Z);
        Veh = CreateVehicle(id,X,Y,Z,0.0,cor1,cor2,60000);
        format(pp, sizeof(pp), "O admin %s o criou um carro(ID DO CARRO %d )", Nome(playerid),Veh);
        SendClientMessageToAll(-1, pp);
    }
    return true;
}
-GooGle- is offline   Reply With Quote
Old 03/03/2013, 01:20 AM   #2
vitorvlv
Huge Clucker
 
vitorvlv's Avatar
 
Join Date: Jan 2012
Location: Brasil
Posts: 252
Reputation: 4
Default Re: Não está criando o carro,comando /veh

pawn Code:
CMD:veh(playerid, params[])
{
    new cor1,cor2,Veh,carid
    if (sscanf(params, "ddd",carid,cor1,cor2))
    {
        SendClientMessage(playerid, -1, "Use: /veh [carid] [cor1] [cor2]");
    }
    else
    {
        if (Admin[playerid] == 0) return SendClientMessage(playerid, 2, "Você não é Admin!");
        new pp[128],Float:X,Float:Y,Float:Z;
        GetPlayerPos(playerid,X,Y,Z);
        Veh = CreateVehicle(id,X,Y,Z,0.0,cor1,cor2,60000);
       PutPlayerInVehicle(playerid, Veh, 0);  
      format(pp, sizeof(pp), "O admin %s o criou um carro(ID DO CARRO %d )", Nome(playerid),carid);
        SendClientMessageToAll(-1, pp);
    }
    return true;
}
__________________
Voltando ao samp depois de alguns anos.

Super enferrujado.


Projeto:

[Gamemode]Um rpg. Sem nome. Nem comecei ainda.
vitorvlv is offline   Reply With Quote
Old 03/03/2013, 01:22 AM   #3
-GooGle-
Huge Clucker
 
-GooGle-'s Avatar
 
Join Date: Dec 2010
Posts: 269
Reputation: 6
Default Re: Não está criando o carro,comando /veh

Quote:
Originally Posted by vitorvlv View Post
pawn Code:
CMD:veh(playerid, params[])
{
    new cor1,cor2,Veh,carid
    if (sscanf(params, "ddd",carid,cor1,cor2))
    {
        SendClientMessage(playerid, -1, "Use: /veh [carid] [cor1] [cor2]");
    }
    else
    {
        if (Admin[playerid] == 0) return SendClientMessage(playerid, 2, "Você não é Admin!");
        new pp[128],Float:X,Float:Y,Float:Z;
        GetPlayerPos(playerid,X,Y,Z);
        Veh = CreateVehicle(id,X,Y,Z,0.0,cor1,cor2,60000);
       PutPlayerInVehicle(playerid, Veh, 0);  
      format(pp, sizeof(pp), "O admin %s o criou um carro(ID DO CARRO %d )", Nome(playerid),carid);
        SendClientMessageToAll(-1, pp);
    }
    return true;
}
Não pegou lek :/...mas valeu por ter tentado
-GooGle- is offline   Reply With Quote
Old 03/03/2013, 01:34 AM   #4
vitorvlv
Huge Clucker
 
vitorvlv's Avatar
 
Join Date: Jan 2012
Location: Brasil
Posts: 252
Reputation: 4
Default Re: Não está criando o carro,comando /veh

antes eu só tinha dado uma olhada rapida no seu comando,mas agora eu fiquei bravo por não ter pegado e criei um :P

Não coloquei oque tem no seu gm,tipo a cor,e o bloqueio para apenas adms poderem usar,isso você faz.
O comando está funcionando perfeitamente xD
pawn Code:
CMD:veh(playerid,params[])
{
new idcar,msg[120],cor1,cor2,Float:p[3],Float:a,carro;
if(sscanf(params,"ddd",idcar,cor1,cor2)) return SendClientMessage(playerid,vermelho,"Use /veh [id do carro] [cor1] [cor2]");

GetPlayerPos(playerid,p[0],p[1],p[2]);
GetPlayerFacingAngle(playerid,a);
carro = CreateVehicle(idcar,p[0],p[1],p[2],a,cor1,cor2,6000);

 PutPlayerInVehicle(playerid, carro, 0);
 format(msg,100,"O Admin criou o veiculo de id %d",idcar);
 SendClientMessageToAll(-1,msg);
 return true;
 }
__________________
Voltando ao samp depois de alguns anos.

Super enferrujado.


Projeto:

[Gamemode]Um rpg. Sem nome. Nem comecei ainda.
vitorvlv is offline   Reply With Quote
Old 03/03/2013, 01:53 AM   #5
-GooGle-
Huge Clucker
 
-GooGle-'s Avatar
 
Join Date: Dec 2010
Posts: 269
Reputation: 6
Default Re: Não está criando o carro,comando /veh

Quote:
Originally Posted by vitorvlv View Post
antes eu só tinha dado uma olhada rapida no seu comando,mas agora eu fiquei bravo por não ter pegado e criei um :P

Não coloquei oque tem no seu gm,tipo a cor,e o bloqueio para apenas adms poderem usar,isso você faz.
O comando está funcionando perfeitamente xD
pawn Code:
CMD:veh(playerid,params[])
{
new idcar,msg[120],cor1,cor2,Float:p[3],Float:a,carro;
if(sscanf(params,"ddd",idcar,cor1,cor2)) return SendClientMessage(playerid,vermelho,"Use /veh [id do carro] [cor1] [cor2]");

GetPlayerPos(playerid,p[0],p[1],p[2]);
GetPlayerFacingAngle(playerid,a);
carro = CreateVehicle(idcar,p[0],p[1],p[2],a,cor1,cor2,6000);

 PutPlayerInVehicle(playerid, carro, 0);
 format(msg,100,"O Admin criou o veiculo de id %d",idcar);
 SendClientMessageToAll(-1,msg);
 return true;
 }
Não funfou também lek,eu to achando que é no meu gm,alguma definição de carros esteja impedindo isso ou tenha chegado no maximo de carros definidos,mas valeu mesmo de coração,vou te reputar.
-GooGle- is offline   Reply With Quote
Old 03/03/2013, 01:56 AM   #6
vitorvlv
Huge Clucker
 
vitorvlv's Avatar
 
Join Date: Jan 2012
Location: Brasil
Posts: 252
Reputation: 4
Default Re: Não está criando o carro,comando /veh

Vish,deve ser no seu gm mesmo então.
No meu funcionou de boa :c
boa sorte ai pra ti,tomara que você consiga
__________________
Voltando ao samp depois de alguns anos.

Super enferrujado.


Projeto:

[Gamemode]Um rpg. Sem nome. Nem comecei ainda.
vitorvlv is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Tutorial] Criando um carro xolp25 Lançamentos/Releases 25 08/01/2013 06:49 PM
[Tutorial] Criando Portão Sem Comando CaozinhoDosCorre Lançamentos/Releases 11 11/10/2012 10:37 PM
[Ajuda] Como verificar se um carro está voando? UkTaKe Português/Portuguese 5 31/08/2012 09:19 PM
[Ajuda] Criando mapa com carro Felipe_Freeze Português/Portuguese 7 26/01/2012 09:54 PM
[Tutorial] Criando carro pelo pawno BurnouT_ Lançamentos/Releases 9 13/11/2010 04:06 PM


All times are GMT. The time now is 08:54 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.