SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 25/12/2014, 05:35 PM   #1
Lynn
Gangsta
 
Lynn's Avatar
 
Join Date: Jan 2010
Location: Detroit, Michigan USA
Posts: 937
Reputation: 108
Default Y_Ini Only saving on LocalHost

When I create a new account, and log out the player file is created i.e TestPlayer.cfg
However no data is saved to the file, it's just empty.
But on LocalHost it stores everything accordingly how it should and works perfect.
What's the problem? I'm using all the same Includes, etc. On my Host as I am localhost.
__________________
Former developer at Next Generation Gaming
Lynn is offline   Reply With Quote
Old 25/12/2014, 09:22 PM   #2
AndySedeyn
High-roller
 
AndySedeyn's Avatar
 
Join Date: Feb 2014
Location: Belgium
Posts: 1,206
Reputation: 681
Default Re: Y_Ini Only saving on LocalHost

I am experiencing the same problem.
AndySedeyn is offline   Reply With Quote
Old 25/12/2014, 09:25 PM   #3
TheSnaKe
Gangsta
 
TheSnaKe's Avatar
 
Join Date: Apr 2013
Location: World of idiots.
Posts: 749
Reputation: 38
Default Re: Y_Ini Only saving on LocalHost

Does it says that all the plugins are running correctly?
TheSnaKe is offline   Reply With Quote
Old 25/12/2014, 09:29 PM   #4
AndySedeyn
High-roller
 
AndySedeyn's Avatar
 
Join Date: Feb 2014
Location: Belgium
Posts: 1,206
Reputation: 681
Default Re: Y_Ini Only saving on LocalHost

Yes, my plugins are up-to-date and they run just fine on both my host and my localhost.
I have tried with a different gamemode (Just the login/register system) and it still occurs.
AndySedeyn is offline   Reply With Quote
Old 25/12/2014, 10:38 PM   #5
Lynn
Gangsta
 
Lynn's Avatar
 
Join Date: Jan 2010
Location: Detroit, Michigan USA
Posts: 937
Reputation: 108
Default Re: Y_Ini Only saving on LocalHost

All plugins are loading correctly, although if they weren't it'd throw a Runtime 19 error.
Also Y_INI is file based, not plugin based.
__________________
Former developer at Next Generation Gaming
Lynn is offline   Reply With Quote
Old 25/12/2014, 10:52 PM   #6
gtakillerIV
Gangsta
 
gtakillerIV's Avatar
 
Join Date: Sep 2011
Location: UAE, Sharjah.
Posts: 985
Reputation: 201
Default Re: Y_Ini Only saving on LocalHost

Check your directory permissions.
gtakillerIV is offline   Reply With Quote
Old 25/12/2014, 10:52 PM   #7
Vukilore
Huge Clucker
 
Vukilore's Avatar
 
Join Date: Jan 2011
Location: http://forum.sa-mp-fr.com/index.php
Posts: 300
Reputation: 110
Default Re : Y_Ini Only saving on LocalHost

Are you running on Linux ? Does it has all right to write/modify ?
__________________
http://forum.sa-mp-fr.com/index.php. << here rest the french forum, in piece.
Vukilore is offline   Reply With Quote
Old 25/12/2014, 11:36 PM   #8
Lynn
Gangsta
 
Lynn's Avatar
 
Join Date: Jan 2010
Location: Detroit, Michigan USA
Posts: 937
Reputation: 108
Default Re: Y_Ini Only saving on LocalHost

Quote:
Originally Posted by gtakillerIV View Post
Check your directory permissions.
Not sure how to do that.
Quote:
Originally Posted by Vukilore View Post
Are you running on Linux ? Does it has all right to write/modify ?
Windows, on both.
And not sure how to edit that. I don't use FTP Often.
__________________
Former developer at Next Generation Gaming
Lynn is offline   Reply With Quote
Old 25/12/2014, 11:37 PM   #9
AndySedeyn
High-roller
 
AndySedeyn's Avatar
 
Join Date: Feb 2014
Location: Belgium
Posts: 1,206
Reputation: 681
Default Re: Y_Ini Only saving on LocalHost

As for me: I CHMOD'ed the entire directory and it still occurs.

EDIT:

Quote:
Originally Posted by Lynn View Post
Not sure how to do that.
Windows, on both.
And not sure how to edit that. I don't use FTP Often.
Right click the folder > File Permissions (Last option), as far as I know.
AndySedeyn is offline   Reply With Quote
Old 26/12/2014, 12:23 AM   #10
Lynn
Gangsta
 
Lynn's Avatar
 
Join Date: Jan 2010
Location: Detroit, Michigan USA
Posts: 937
Reputation: 108
Default Re: Y_Ini Only saving on LocalHost

When I set permissions, then select okay, I open permissions back up and it's all reset again.
It's not saving my permissions to 'write'
__________________
Former developer at Next Generation Gaming
Lynn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
y_ini Not saving ... rockhopper Scripting Help 8 28/05/2014 03:43 PM
Saving pos with y_ini siemka321 Scripting Help 1 15/07/2013 12:21 PM
y_ini and saving BigGroter Scripting Help 0 10/05/2013 09:53 PM
Y_INI saving help 69 Scripting Help 9 02/12/2012 12:30 PM
[HELP] saving IPs in y_ini? olabv Server Support 1 10/12/2011 11:36 AM


All times are GMT. The time now is 01:03 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.