SA-MP Forums

Go Back   SA-MP Forums > SA-MP Server > Server Support

Reply
 
Thread Tools Display Modes
Old 05/05/2017, 05:33 PM   #11
TonyII
Huge Clucker
 
Join Date: Aug 2013
Posts: 340
Reputation: 58
Default Re: Segmentation Fault?

Quote:
Originally Posted by Dignity View Post
Are you streaming the objects inside the filterscript?

What about the gamemode? Are you using the streamer plugin there?
Yea I'm using the streamer in all the filterscripts and also in the gamemode, I excluded the filterscripts because I didn't compile those yet with the new plugin. For now it's only the gamemode itself and the streamer plugin
TonyII is offline   Reply With Quote
Old 05/05/2017, 05:33 PM   #12
Vince
Spam Machine
 
Vince's Avatar
 
Join Date: Sep 2007
Location: Belgium
Posts: 10,066
Reputation: 2660
Default Re: Segmentation Fault?

Save this script in your server directory as a .sh file (e.g. start.sh). Set the file to be executable (e.g. sudo chmod +x start.sh). Then run this file instead of samp03svr to start the server (so ./start.sh instead of ./samp03svr). It should give a more detailed output in the crash logs.

Code:
echo 0 | gdb -batch-silent -ex "run" -ex "set logging overwrite on" -ex "set logging file last_crash.log" -ex "set logging on" -ex "set pagination off" -ex "handle SIG33 pass nostop noprint" -ex "echo backtrace:\n" -ex "backtrace full" -ex "echo \n\nregisters:\n" -ex "info registers" -ex "echo \n\ncurrent instructions:\n" -ex "x/16i \$pc" -ex "echo \n\nthreads backtrace:\n" -ex "thread apply all backtrace" -ex "echo \n\nMemory map:\n" -ex "info files" -ex "set logging off" -ex "quit" samp03svr
date >> crash.log
cat last_crash.log >> crash.log
You need gdb (sudo yum install gdb).
__________________
Vince is offline   Reply With Quote
Old 05/05/2017, 05:34 PM   #13
Dignity
High-roller
 
Dignity's Avatar
 
Join Date: May 2013
Location: Belgium
Posts: 1,661
Reputation: 1211
Default Re: Segmentation Fault?

Quote:
Originally Posted by TonyII View Post
Yea I'm using the streamer in all the filterscripts and also in the gamemode, I excluded the filterscripts because I didn't compile those yet with the new plugin. For now it's only the gamemode itself and the streamer plugin
I just updated my plugin to 2.9.1 and it loads just fine.

You could try http://forum.sa-mp.com/showthread.php?t=249226 ─ maybe this can pinpoint what's going on
Dignity is offline   Reply With Quote
Old 05/05/2017, 05:50 PM   #14
TonyII
Huge Clucker
 
Join Date: Aug 2013
Posts: 340
Reputation: 58
Default Re: Segmentation Fault?

Quote:
Originally Posted by Vince View Post
Save this script in your server directory as a .sh file (e.g. start.sh). Set the file to be executable (e.g. sudo chmod +x start.sh). Then run this file instead of samp03svr to start the server (so ./start.sh instead of ./samp03svr). It should give a more detailed output in the crash logs.

Code:
echo 0 | gdb -batch-silent -ex "run" -ex "set logging overwrite on" -ex "set logging file last_crash.log" -ex "set logging on" -ex "set pagination off" -ex "handle SIG33 pass nostop noprint" -ex "echo backtrace:\n" -ex "backtrace full" -ex "echo \n\nregisters:\n" -ex "info registers" -ex "echo \n\ncurrent instructions:\n" -ex "x/16i \$pc" -ex "echo \n\nthreads backtrace:\n" -ex "thread apply all backtrace" -ex "echo \n\nMemory map:\n" -ex "info files" -ex "set logging off" -ex "quit" samp03svr
date >> crash.log
cat last_crash.log >> crash.log
You need gdb (sudo yum install gdb).
I've followed your steps, once executed it said [1]+ Done

The server logs:

Code:
----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[19:33:45] filterscripts = ""  (string)
[19:33:45] 
[19:33:45] Server Plugins
[19:33:45] --------------
[19:33:45]  Loading plugin: nativechecker.so
[19:33:45]   Loaded.
[19:33:45]  Loading plugin: streamer.so
[19:33:45] 

*** Streamer Plugin v2.8.2 by Incognito loaded ***

[19:33:45]   Loaded.
[19:33:45]  Loading plugin: sscanf.so
[19:33:45] 

[19:33:45]  ===============================

[19:33:45]       sscanf plugin loaded.     

[19:33:45]          Version:  2.8.2        

[19:33:45]    (c) 2012 Alex "******" Cole  

[19:33:45]  ===============================

[19:33:45]   Loaded.
[19:33:45]  Loaded 3 plugins.

[19:33:45] 
[19:33:45] Filterscripts
[19:33:45] ---------------
[19:33:45]   Loaded 0 filterscripts.

Quote:
Originally Posted by Dignity View Post
I just updated my plugin to 2.9.1 and it loads just fine.

You could try http://forum.sa-mp.com/showthread.php?t=249226 ─ maybe this can pinpoint what's going on
I tried it out, don't know if I'm doing anything wrong but the logs still don't show any error
TonyII is offline   Reply With Quote
Old 05/05/2017, 06:14 PM   #15
Sew_Sumi
Banned
 
Join Date: Jun 2008
Location: Azerbaijan
Posts: 6,242
Reputation: 525
Default Re: Segmentation Fault?

Quote:
Originally Posted by Wyu View Post
IMPORTANT: In order to make it work correcly you must put it in the end of the plugins line of your server.cfg so it will be the last one, e.g. plugins sscanf streamer nativechecker.
commonly missed instruction. Don't know if it is directly related or not.
Sew_Sumi is offline   Reply With Quote
Old 05/05/2017, 06:18 PM   #16
Vince
Spam Machine
 
Vince's Avatar
 
Join Date: Sep 2007
Location: Belgium
Posts: 10,066
Reputation: 2660
Default Re: Segmentation Fault?

Quote:
Originally Posted by TonyII View Post
I've followed your steps, once executed it said [1]+ Done
The script writes logs to different files. There should be crash.log and last_crash.log.
__________________
Vince is offline   Reply With Quote
Old 05/05/2017, 06:20 PM   #17
TonyII
Huge Clucker
 
Join Date: Aug 2013
Posts: 340
Reputation: 58
Default Re: Segmentation Fault?

Quote:
Originally Posted by Sew_Sumi View Post
commonly missed instruction. Don't know if it is directly related or not.
My bad, this is what I get now:

Code:
----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[20:09:34] filterscripts = ""  (string)
[20:09:34] 
[20:09:34] Server Plugins
[20:09:34] --------------
[20:09:34]  Loading plugin: streamer.so
[20:09:34] 

*** Streamer Plugin v2.8.2 by Incognito loaded ***

[20:09:34]   Loaded.
[20:09:34]  Loading plugin: sscanf.so
[20:09:34] 

[20:09:34]  ===============================

[20:09:34]       sscanf plugin loaded.     

[20:09:34]          Version:  2.8.2        

[20:09:34]    (c) 2012 Alex "******" Cole  

[20:09:34]  ===============================

[20:09:34]   Loaded.
[20:09:34]  Loading plugin: nativechecker.so
[20:09:34]   Loaded.
[20:09:34]  Loaded 3 plugins.

[20:09:34] 
[20:09:34] Filterscripts
[20:09:34] ---------------
[20:09:34]   Loaded 0 filterscripts.

Edit:

From the last_crash I got this:

Code:
backtrace:
No stack.

registers:
The program has no registers now.

current instructions:
No registers.


threads backtrace:


Memory map:
And the other one this:
Code:
backtrace:
No stack.


registers:
The program has no registers now.


current instructions:
No registers.


threads backtrace:


Memory map:
backtrace:
No stack.


registers:
The program has no registers now.


current instructions:
No registers.


threads backtrace:


Memory map:
backtrace:
No stack.


registers:
The program has no registers now.


current instructions:
No registers.


threads backtrace:


Memory map:
TonyII is offline   Reply With Quote
Old 05/05/2017, 07:50 PM   #18
Sew_Sumi
Banned
 
Join Date: Jun 2008
Location: Azerbaijan
Posts: 6,242
Reputation: 525
Default Re: Segmentation Fault?

Check you've uploaded the AMX correctly. Try reuploading it.

If that doesn't work, post up your server.cfg without the RCON password.
Sew_Sumi is offline   Reply With Quote
Old 05/05/2017, 08:10 PM   #19
TonyII
Huge Clucker
 
Join Date: Aug 2013
Posts: 340
Reputation: 58
Default Re: Segmentation Fault?

Quote:
Originally Posted by Sew_Sumi View Post
Check you've uploaded the AMX correctly. Try reuploading it.

If that doesn't work, post up your server.cfg without the RCON password.
I had tried to reupload all the files plenty of times, sadly it didn't do anything for me. I've decided to try out debian, the only problem so far is that it denies access for root on putty trying to ****** my way out of that problem but if anyone would know the solution here I would be grateful to know.
TonyII is offline   Reply With Quote
Old 05/05/2017, 09:11 PM   #20
fatlirmorina
Big Clucker
 
Join Date: Nov 2013
Posts: 70
Reputation: 1
Default Re: Segmentation Fault?

does it happen each time u try to join?
fatlirmorina is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Segmentation Fault +REP ShinichiKudou Scripting Help 16 22/02/2014 05:28 PM
Segmentation Fault hassantariq73 Server Support 3 21/12/2013 12:23 PM
Segmentation fault?? Lisaax Server Support 3 17/06/2013 11:47 AM
Segmentation fault Cool_Boy27 Server Support 9 06/07/2011 11:30 AM
segmentation fault Suppenhuhn92 Server Support 15 08/02/2009 10:53 AM


All times are GMT. The time now is 12:15 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.