SA-MP Forums

Go Back   SA-MP Forums > Non-English > Languages > Português/Portuguese

Reply
 
Thread Tools Display Modes
Old 01/06/2020, 05:59 AM   #1
ReturnZero
Little Clucker
 
Join Date: May 2020
Posts: 14
Reputation: 0
Default Debug servidor

Olá amigos uma das minhas callbacks está apresentando o seguinte debug com o crash detect, no serbido em si, não está apresentando erros, mas nos logs, está aparecendo esse debug, esse erro geralmente se dá por qual motivo?

Code:
[debug]  Accessing element at index 900 past array upper bound 12
[debug] AMX backtrace:
[debug] #0 000bcdec in public OnPlayerAtualizador (playerid=8) at C:\Users\Master01\Servidor\gamemodes\city.pwn:11117
[debug] Run time error 4: "Array index out of bounds"
ReturnZero is offline   Reply With Quote
Old 01/06/2020, 08:35 AM   #2
Vasco
Little Clucker
 
Vasco's Avatar
 
Join Date: Jan 2014
Location: Portugal
Posts: 33
Reputation: 2
Default Re: Debug servidor

algo nesse "public" tens um pedaço de código em que queres aceder a um elemento no numero 900 quando o máximo é so 12
Vasco is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[12:02:57] [debug] Run time error 4: "Array index out of bounds" [12:02:57] [debug] Attempted to read/write array eleme sonn51280 Scripting Help 5 13/07/2019 01:08 PM
[Ajuda] Debug no servidor broberto28 Português/Portuguese 2 11/02/2019 01:27 PM
[debug] help HypCosmin Scripting Help 2 11/12/2018 08:42 AM
[Ajuda] Ataque de Hackers deixando Servidor em Debug MarllonGTA Português/Portuguese 6 28/07/2015 10:18 PM
[Ajuda] Player sai do servidor, servidor dá close. MorreJaa Português/Portuguese 7 14/12/2014 01:22 AM


All times are GMT. The time now is 09:04 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.