SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Plugin Development

Reply
 
Thread Tools Display Modes
Old 23/12/2018, 02:14 AM   #1
Graber
Big Clucker
 
Graber's Avatar
 
Join Date: Mar 2013
Location: Germany
Posts: 118
Reputation: 142
Default samp-compat: Client version intercompatibility plugin

samp-compat



Allow connections from previously incompatible SA-MP clients into newer or older servers allowing you to have players from 2 versions playing together without additional software


Supported versions
  • 0.3.7-R2 (both R2-1 and R2-2): Supports clients from 0.3.DL
  • 0.3.DL: Supports clients from 0.3.7 (R1, R2 and R3)


Installation

Simply install to your project:

Code:
sampctl package install AGraber/samp-compat
Optionally, include in your code:

Code:
#include <compat>

Building

This repo took Southclaws' SA-MP plugin boilerplate, very detailed instructions of building can be found there.


Thanks to
  • SA-MP server structures provided by contributors of the YSF plugin: files containing this are governed by its MPL 1.1 license
  • Southclaws for his neat boilerplate
  • SA-MP Team for making versions incompatible for some reason, allowing me to release this plugin

Last edited by Graber; 23/12/2018 at 01:35 PM.
Graber is offline   Reply With Quote
Old 23/12/2018, 02:25 AM   #2
cuber
Gangsta
 
cuber's Avatar
 
Join Date: Oct 2016
Location: CookieDM - https://discord.gg/p7ahv8s
Posts: 920
Reputation: 171
Default Re: samp-compat: Client version intercompatibility plugin

This will definetly get in handy for everyone, thanks!
cuber is offline   Reply With Quote
Old 23/12/2018, 02:44 AM   #3
SyS
High-roller
 
SyS's Avatar
 
Join Date: Oct 2015
Posts: 2,056
Reputation: 494
Default Re: samp-compat: Client version intercompatibility plugin

Nice
SyS is offline   Reply With Quote
Old 23/12/2018, 03:08 AM   #4
Romz
High-roller
 
Romz's Avatar
 
Join Date: Jun 2013
Location: Ukraine
Posts: 1,085
Reputation: 64
Default Re: samp-compat: Client version intercompatibility plugin

R3 supported?

https://forum.sa-mp.com/showthread.php?t=661491
__________________
Romz is offline   Reply With Quote
Old 23/12/2018, 01:35 PM   #5
Graber
Big Clucker
 
Graber's Avatar
 
Join Date: Mar 2013
Location: Germany
Posts: 118
Reputation: 142
Default Re: samp-compat: Client version intercompatibility plugin

Quote:
Originally Posted by Romz View Post
Yes, net code and internal version haven't changed. I updated the README to explicitly state that.

Also, I pushed the release version to 0.1.1 to upload a binary without debug prints, which aren't necesary anymore since I already tested this a bit. Just a bit more until I can consider this stable.
Graber is offline   Reply With Quote
Old 23/12/2018, 05:33 PM   #6
Chaprnks
Gangsta
 
Chaprnks's Avatar
 
Join Date: Sep 2007
Location: Soviet America
Posts: 762
Reputation: 64
Default Re: samp-compat: Client version intercompatibility plugin



Any dependencies the plugin requires to load?
__________________
Chaprnks is offline   Reply With Quote
Old 26/12/2018, 12:22 AM   #7
RogueDrifter
High-roller
 
RogueDrifter's Avatar
 
Join Date: Dec 2017
Location: SA-MP Drifting world.
Posts: 1,242
Reputation: 379
Default Re: samp-compat: Client version intercompatibility plugin

Hey nice!
__________________
Be creative.

[Github]:Link [Gists]:Link [Forum]:Link [Server]:Link [Discord]:Link


RogueDrifter is offline   Reply With Quote
Old 26/12/2018, 04:08 AM   #8
Verc
Big Clucker
 
Verc's Avatar
 
Join Date: Apr 2018
Location: 🇯🇵
Posts: 178
Reputation: 29
Default Re: samp-compat: Client version intercompatibility plugin

so the difference is this is two includes in one plugin,right? or is there any difference?

Thank you Graber,very cool.
Verc is offline   Reply With Quote
Old 26/12/2018, 01:26 PM   #9
tandytanz
Big Clucker
 
tandytanz's Avatar
 
Join Date: Nov 2011
Location: Indonesia
Posts: 102
Reputation: 10
Default Re: samp-compat: Client version intercompatibility plugin

what if we had any new models to download ?
tandytanz is offline   Reply With Quote
Old 26/12/2018, 01:43 PM   #10
iorp
Big Clucker
 
iorp's Avatar
 
Join Date: Sep 2018
Location: India
Posts: 52
Reputation: 1
Default Re: samp-compat: Client version intercompatibility plugin

Good Work, very useful to run single server for all versions. but explain the 0.3 DL supported feature, are they supported or not?
__________________
Indian Ocean Roleplay

iorp is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Include] samp-compat: Backwards and forward compatibility libraries between server-client (Old IsClient03DL) Graber Includes 33 18/11/2018 01:03 PM
[FilterScript] Check Client Version [BOPE]Seu._.Madruga Lançamentos/Releases 11 17/04/2018 04:15 AM
SAMP Add a 'A new version of samp is available' text at the start of samp client. Tomboeg General 16 29/03/2013 07:06 PM
New version of sa-mp client? nGen.SoNNy Everything and Nothing 1 09/12/2012 06:36 PM


All times are GMT. The time now is 01:20 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.