SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Plugin Development

Reply
 
Thread Tools Display Modes
Old 26/12/2018, 03:45 PM   #11
Logic_
High-roller
 
Logic_'s Avatar
 
Join Date: Jun 2015
Location: Pakistan
Posts: 1,571
Reputation: 290
Default Re: samp-compat: Client version intercompatibility plugin

Brilliant.
__________________
Developer @ Nevada State Prison RP/ Core Roleplay;

Cheap game-host (SA-MP, SA-MP Hosted tab, G-MOD etc) @ www.prestigesteve.com

Former developer @ COD:BO3, COD:AW, I:RP, PC:RP, NEG, ZL TDM, CookieDM and IW:TDM.

  • You can't forcefully correct someone and you shouldn't waste your time on it because you can bring a horse to water but can't force it to drink.
  • Please don't message me asking for help, because by doing that, you're only limiting your support to one person when the whole community can help you here. Refer to scripting help section instead.
Logic_ is offline   Reply With Quote
Old 28/12/2018, 07:01 AM   #12
RoboN1X
Huge Clucker
 
RoboN1X's Avatar
 
Join Date: Feb 2011
Location: Indonesia
Posts: 346
Reputation: 60
Default Re: samp-compat: Client version intercompatibility plugin

Is the release binary version for windows built on debug mode? it says vcruntime140d.dll is missing. I do have the redistributable package x86 installed on Windows 7 SP1 x64. I just don't have Visual Studio installed.
__________________
Need Help? Use Search, WIKI, and FAQ
RoboN1X is offline   Reply With Quote
Old 28/12/2018, 02:48 PM   #13
Graber
Big Clucker
 
Graber's Avatar
 
Join Date: Mar 2013
Location: Germany
Posts: 121
Reputation: 142
Default Re: samp-compat: Client version intercompatibility plugin

Quote:
Originally Posted by RoboN1X View Post
Is the release binary version for windows built on debug mode? it says vcruntime140d.dll is missing. I do have the redistributable package x86 installed on Windows 7 SP1 x64. I just don't have Visual Studio installed.
Quote:
Originally Posted by Chaprnks View Post


Any dependencies the plugin requires to load?
Thanks for pointing that out! I've forgotten to change the build settings while publishing, I'll bump the version to update the binary shortly when I can get a VS setup working.

Quote:
Originally Posted by Verc View Post
so the difference is this is two includes in one plugin,right? or is there any difference?

Thank you Graber,very cool.
The include version has a flaw that couldn't be fixed with the Pawn.RakNet plugin: Global objects weren't being streamed to 0.3.7 clients on 0.3.DL servers because of OnPlayerFinishedDownloading not being called for 0.3.7. This include calls it for the client to emulate a 0.3.DL, but be aware that the client isn't actually downloading anything!

Quote:
Originally Posted by iorp View Post
Good Work, very useful to run single server for all versions. but explain the 0.3 DL supported feature, are they supported or not?
0.3.DL features (such as custom objects) aren't supported on 0.3.7 and 0.3.DL packets sent to 0.3.7 clients will be dropped or rewritten to a compatible version (ej. Custom skins being replaced with the set base id)
Graber is offline   Reply With Quote
Old 09/01/2019, 08:35 AM   #14
Qrauzer
Little Clucker
 
Join Date: Jan 2018
Posts: 1
Reputation: 0
Default Re: samp-compat: Client version intercompatibility plugin

Hi there. Is it possible to create a plugin that will allow client 0.3e connect to server 0.3.7?

And if it is, can u do it for private usage?)
Qrauzer is offline   Reply With Quote
Old 09/01/2019, 01:25 PM   #15
HNIC
Big Clucker
 
HNIC's Avatar
 
Join Date: Jun 2017
Location: Downtown
Posts: 56
Reputation: 4
Default Re: samp-compat: Client version intercompatibility plugin

Quote:
Originally Posted by Qrauzer View Post
Hi there. Is it possible to create a plugin that will allow client 0.3e connect to server 0.3.7?

And if it is, can u do it for private usage?)
Just wondering, why would anybody use 0.3e in 2019?
HNIC is offline   Reply With Quote
Old 09/01/2019, 01:27 PM   #16
Spmn
Gangsta
 
Join Date: Jun 2015
Location: Romania
Posts: 532
Reputation: 131
Default Re: samp-compat: Client version intercompatibility plugin

Quote:
Originally Posted by Qrauzer View Post
Hi there. Is it possible to create a plugin that will allow client 0.3e connect to server 0.3.7?

And if it is, can u do it for private usage?)
It is, but it'll take much more work because every packet/rpc structure has changed since then.
Spmn is offline   Reply With Quote
Old 09/01/2019, 02:45 PM   #17
SymonClash
Big Clucker
 
SymonClash's Avatar
 
Join Date: Dec 2018
Posts: 121
Reputation: 8
Default Re: samp-compat: Client version intercompatibility plugin

Since i'm not using sampctl, where i can find the download of this plugin?
SymonClash is online now   Reply With Quote
Old 09/01/2019, 04:31 PM   #18
Infra
Big Clucker
 
Infra's Avatar
 
Join Date: Feb 2014
Location: Germany
Posts: 86
Reputation: 19
Default Re: samp-compat: Client version intercompatibility plugin

Quote:
Originally Posted by SymonClash View Post
Since i'm not using sampctl, where i can find the download of this plugin?
https://github.com/AGraber/samp-compat/releases



Infra is offline   Reply With Quote
Old 09/01/2019, 06:30 PM   #19
Pottus
Godfather
 
Pottus's Avatar
 
Join Date: Jun 2012
Posts: 5,345
Reputation: 1271
Default Re: samp-compat: Client version intercompatibility plugin

Just going to say it is a neat plugin but at the same time also absolutely stupid. The reason for that is when a new SA-MP version comes out the changes could be too many significant changes making cross compatibility useless. Just seems to me this feature is not really needed I am sure some will argue that but the only use I could see is a new client connecting to a older version server even then why not just do it properly?
Pottus is offline   Reply With Quote
Old 09/01/2019, 06:35 PM   #20
Crayder
High-roller
 
Crayder's Avatar
 
Join Date: Sep 2013
Location: Flames of Hell
Posts: 3,853
Reputation: 610
Default Re: samp-compat: Client version intercompatibility plugin

Quote:
Originally Posted by HNIC View Post
Just wondering, why would anybody use 0.3e in 2019?
My guess is the "mods allowed" server or playing with sob since 0.3e was when sob reaaaly blew up with features and got too damn popular... But I like playing with old versions just for fun and learning purposes, if you can find the older than old versions you'd prolly be amazed.

Speaking of mods/hacks... if a player was to connect to a 0.3.7 server using this plugin with a 0.3x client and 0.3x restricted mods, would this plugin make said mods compatible with 0.3.7 or make version specific features useless? If version specific mods are rendered useless (obviously excluding MOST things like airbreak) then that could be another use of this plugin, but otherwise I feel it's most secure and stable to just use the same version.
__________________
Those who deserve reputation, do not need to beg for it.
Also, don't expect the help you need when offering reputation, you'll just be attracting Rep Hunters.
Join SA-MP Discord!
Crayder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Include] samp-compat: Backwards and forward compatibility libraries between server-client (Old IsClient03DL) Graber Includes 33 18/11/2018 01:03 PM
[FilterScript] Check Client Version [BOPE]Seu._.Madruga Lançamentos/Releases 11 17/04/2018 04:15 AM
SAMP Add a 'A new version of samp is available' text at the start of samp client. Tomboeg General 16 29/03/2013 07:06 PM
New version of sa-mp client? nGen.SoNNy Everything and Nothing 1 09/12/2012 06:36 PM


All times are GMT. The time now is 01:51 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.