SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 17/12/2016, 10:29 PM   #1
denNorske
Gangsta
 
denNorske's Avatar
 
Join Date: Nov 2011
Location: Oslo, Norway
Posts: 787
Reputation: 95
Default Server causes frequent client crashes (mostly 0x6BD)

Hello sa-mp forums.

I've had major issues lately with my clients timing out from the server. It happens very frequently, and many face severe issues playing on the server. I'm quite sure this is not related to mods or map objects - as the crashes and issues remain even with all cars and objects removed.

So lets assume this is a pure script issue, server sided.

There are really no connections to find by monitoring each player until they crash. Some play for 3 minutes, someone crash just after logging in, and other crash after hours of playtime. And it doesn't matter what they do, or where they are.

I found the most common crash SCM Op's to be:

1. 0x6BD - which is something related to if there is anything in the sight between two coordinates. Is_line_of_sight_clear according to GTAGaming's OPcode database.

2. 0x470 - get_current_car_weapon - assume it has something to do about checking which weapons that's visible or not at the player peds?

3. 0x2BF - "if vehicle is submerged in water" - it's a bit less common, but appears a few times.


Those codes are retrieved by the community that has contributed their crash logs each time they crashed.

I also added a script that would check for illegal vehicle parts on all the vehicles, to avoid the crashes there.
Does anyone have an idea what I could do to step forward and get this fixed? It's a shame to see players time out so frequently, and at a point they'll get tired of it. I don't have any clue what could cause this.

Thanks

EDIT: This was sorted out. Was a script related issue with house pickups and objects.
__________________
xSF source has been publicly released: Available on git (https://xsfserver.com/?p=1197)
Useful Racespawn generator: https://forum.sa-mp.com/showpost.php...postcount=3777

Last edited by denNorske; 19/04/2017 at 09:30 AM.
denNorske is offline   Reply With Quote
Old 17/12/2016, 10:47 PM   #2
iLearner
Guest
 
Posts: n/a
Default Re: Server causes frequent client crashes (mostly 0x6BD)

When did all this start happening? Recently? In that case the only suggestion I have is check things you've edited / added recently.
  Reply With Quote
Old 17/12/2016, 10:55 PM   #3
denNorske
Gangsta
 
denNorske's Avatar
 
Join Date: Nov 2011
Location: Oslo, Norway
Posts: 787
Reputation: 95
Default Re: Server causes frequent client crashes (mostly 0x6BD)

I wish it was that easy myself, but I am not sure when it started. I just know that it was working in v2 (now it's v3 and has been v3 for almost 2 years).

Else i would have attempted to remove recent features to get it back stable and perhaps fix it before releasing it again Not a bad thought, but not possible to say in my case.
__________________
xSF source has been publicly released: Available on git (https://xsfserver.com/?p=1197)
Useful Racespawn generator: https://forum.sa-mp.com/showpost.php...postcount=3777
denNorske is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
On server restart client crashes SomebodyAndMe Bug Reports 4 22/05/2013 04:11 AM
Client Crashes Just Before Server Login Appears! whatisthe3 Client Support 2 22/12/2011 02:43 PM
Client crashes? NewYorkRP Help Archive 3 28/11/2010 06:00 PM
Client crashes urkiefly101 Server Support 2 21/08/2009 07:09 PM
Client crashes often.. Does my server causes that? SiJ Client Support 8 20/07/2009 01:43 PM


All times are GMT. The time now is 03:25 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.